aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zaurus-updater
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2009-06-06 14:28:08 +0900
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2009-06-06 18:53:38 +0900
commitef47aa19f38d0a17d7c8e1e19b168097e94c2588 (patch)
tree94c377f17f0ae5068ef8f02a92acd8378ec060b6 /recipes/zaurus-updater
parent02ce57eaf0cbc7c659e78a5591cf503f9b286791 (diff)
downloadopenembedded-ef47aa19f38d0a17d7c8e1e19b168097e94c2588.tar.gz
zaurus-installer: add collie support. properly unbreaks collie image build.
* this effectively reverts d4dae3f91c9e0e5391ea5e83751ae0d56cbaabe6 which was not the proper way to do it. Zaurus machine config probably still needs some more TLC.
Diffstat (limited to 'recipes/zaurus-updater')
-rw-r--r--recipes/zaurus-updater/zaurus-installer.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/zaurus-updater/zaurus-installer.bb b/recipes/zaurus-updater/zaurus-installer.bb
index 098110b969..70dca30031 100644
--- a/recipes/zaurus-updater/zaurus-installer.bb
+++ b/recipes/zaurus-updater/zaurus-installer.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Installkit for kexecboot-kernel"
-DEPENDS = "zaurus-updater linux-kexecboot"
-PR = "r0"
+DEPENDS = "${@base_conditional('MACHINE', 'collie', 'linux-kexecboot', 'zaurus-updater linux-kexecboot', d)}"
+PR = "r1"
PACKAGES = ""
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
+COMPATIBLE_MACHINE = '(collie|poodle|c7x0|spitz|akita|tosa)'
S = "${WORKDIR}"
@@ -22,7 +22,9 @@ do_deploy() {
[ -f "${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin" ] && cp ${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin installkit-${MACHINE}/${KERNEL_IMAGETYPE}
- cp updater.sh.${MACHINE} installkit-${MACHINE}/updater.sh
+ if [ ! "${MACHINE}" = "collie" ]; then
+ cp updater.sh.${MACHINE} installkit-${MACHINE}/updater.sh
+ fi
tar czf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz installkit-${MACHINE}/
md5sum ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz > ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5