aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver/xserver-kdrive-git
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xorg-xserver/xserver-kdrive-git
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xorg-xserver/xserver-kdrive-git')
-rw-r--r--recipes/xorg-xserver/xserver-kdrive-git/enable-epson.patch17
-rw-r--r--recipes/xorg-xserver/xserver-kdrive-git/enable-tslib.patch26
-rw-r--r--recipes/xorg-xserver/xserver-kdrive-git/enable-xcalibrate.patch68
-rw-r--r--recipes/xorg-xserver/xserver-kdrive-git/w100-autofoo.patch56
-rw-r--r--recipes/xorg-xserver/xserver-kdrive-git/w100-post-1.4-buildfix.patch12
-rw-r--r--recipes/xorg-xserver/xserver-kdrive-git/xephyr-post-1.4-buildfix.patch11
6 files changed, 190 insertions, 0 deletions
diff --git a/recipes/xorg-xserver/xserver-kdrive-git/enable-epson.patch b/recipes/xorg-xserver/xserver-kdrive-git/enable-epson.patch
new file mode 100644
index 0000000000..23988cb815
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-kdrive-git/enable-epson.patch
@@ -0,0 +1,17 @@
+Index: git/hw/kdrive/Makefile.am
+===================================================================
+--- git.orig/hw/kdrive/Makefile.am 2007-09-08 23:24:21.000000000 +0200
++++ git/hw/kdrive/Makefile.am 2007-09-08 23:24:31.000000000 +0200
+@@ -1,10 +1,10 @@
+ if KDRIVEVESA
+-VESA_SUBDIRS = vesa ati chips epson i810 mach64 mga nvidia pm2 r128 \
++VESA_SUBDIRS = vesa ati chips i810 mach64 mga nvidia pm2 r128 \
+ smi via
+ endif
+
+ if BUILD_KDRIVEFBDEVLIB
+-FBDEV_SUBDIRS = fbdev
++FBDEV_SUBDIRS = fbdev epson
+ endif
+
+ if XFAKESERVER
diff --git a/recipes/xorg-xserver/xserver-kdrive-git/enable-tslib.patch b/recipes/xorg-xserver/xserver-kdrive-git/enable-tslib.patch
new file mode 100644
index 0000000000..bbb4a60a16
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-kdrive-git/enable-tslib.patch
@@ -0,0 +1,26 @@
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2007-09-08 22:17:11.000000000 +0200
++++ git/configure.ac 2007-09-08 22:32:45.000000000 +0200
+@@ -1834,7 +1834,7 @@
+ AC_CHECK_LIB([rt], [nanosleep], XEPHYR_LIBS="$XEPHYR_LIBS -lrt"))
+
+ if test "x$TSLIB" = xyes; then
+- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
+ if test "x$HAVE_TSLIB" = xno; then
+ AC_MSG_ERROR([tslib must be installed to build the tslib driver. See http://tslib.berlios.de/])
+ fi
+@@ -1858,10 +1858,10 @@
+ ;;
+ esac
+ KDRIVE_STUB_LIB='$(top_builddir)/hw/kdrive/src/libkdrivestubs.a'
+- KDRIVE_LOCAL_LIBS="$TSLIB_LIBS $DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB $CONFIG_LIB"
++ KDRIVE_LOCAL_LIBS="$DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB $CONFIG_LIB"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $FB_LIB $MI_LIB $KDRIVE_PURE_LIBS"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $KDRIVE_OS_LIB $OS_LIB"
+- KDRIVE_LIBS="$KDRIVE_LOCAL_LIBS $XSERVERLIBS_LIBS"
++ KDRIVE_LIBS="$TSLIB_LIBS $KDRIVE_LOCAL_LIBS $XSERVERLIBS_LIBS"
+
+ # check if we can build Xephyr
+ PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp, [xephyr="yes"], [xephyr="no"])
diff --git a/recipes/xorg-xserver/xserver-kdrive-git/enable-xcalibrate.patch b/recipes/xorg-xserver/xserver-kdrive-git/enable-xcalibrate.patch
new file mode 100644
index 0000000000..ffd46fb58c
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-kdrive-git/enable-xcalibrate.patch
@@ -0,0 +1,68 @@
+---
+ Xext/Makefile.am | 6 ++++++
+ configure.ac | 9 ++++++++-
+ include/kdrive-config.h.in | 3 +++
+ mi/miinitext.c | 6 ++++++
+ 4 files changed, 23 insertions(+), 1 deletion(-)
+
+Index: git/mi/miinitext.c
+===================================================================
+--- git.orig/mi/miinitext.c 2007-09-08 22:17:19.000000000 +0200
++++ git/mi/miinitext.c 2007-09-08 22:37:51.000000000 +0200
+@@ -374,6 +374,9 @@
+ #ifdef DMXEXT
+ extern void DMXExtensionInit(INITARGS);
+ #endif
++#ifdef XCALIBRATE
++extern void XCalibrateExtensionInit(INITARGS);
++#endif
+ #ifdef XEVIE
+ extern void XevieExtensionInit(INITARGS);
+ #endif
+@@ -666,6 +669,9 @@
+ #ifdef DAMAGE
+ if (!noDamageExtension) DamageExtensionInit();
+ #endif
++#ifdef XCALIBRATE
++ XCalibrateExtensionInit ();
++#endif
+ }
+
+ void
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2007-09-08 22:37:43.000000000 +0200
++++ git/configure.ac 2007-09-08 22:38:36.000000000 +0200
+@@ -505,6 +505,7 @@
+ AC_ARG_ENABLE(xf86misc, AS_HELP_STRING([--disable-xf86misc], [Build XF86Misc extension (default: auto)]), [XF86MISC=$enableval], [XF86MISC=auto])
+ AC_ARG_ENABLE(xace, AS_HELP_STRING([--disable-xace], [Build X-ACE extension (default: enabled)]), [XACE=$enableval], [XACE=yes])
+ AC_ARG_ENABLE(xcsecurity, AS_HELP_STRING([--disable-xcsecurity], [Build Security extension (default: enabled)]), [XCSECURITY=$enableval], [XCSECURITY=$XACE])
++AC_ARG_ENABLE(xcalibrate, AS_HELP_STRING([--enable-xcalibrate], [Build XCalibrate extension (default: disabled)]), [XCALIBRATE=$enableval], [XCALIBRATE=no])
+ AC_ARG_ENABLE(appgroup, AS_HELP_STRING([--disable-appgroup], [Build XC-APPGROUP extension (default: enabled)]), [APPGROUP=$enableval], [APPGROUP=$XCSECURITY])
+ AC_ARG_ENABLE(xcalibrate, AS_HELP_STRING([--enable-xcalibrate], [Build XCalibrate extension (default: disabled)]), [XCALIBRATE=$enableval], [XCALIBRATE=no])
+ AC_ARG_ENABLE(tslib, AS_HELP_STRING([--enable-tslib], [Build kdrive tslib touchscreen support (default: disabled)]), [TSLIB=$enableval], [TSLIB=no])
+@@ -833,6 +834,12 @@
+ AC_DEFINE(XCSECURITY, 1, [Build Security extension])
+ fi
+
++AM_CONDITIONAL(XCALIBRATE, [test "x$XCALIBRATE" = xyes])
++if test "x$XCALIBRATE" = xyes; then
++ AC_DEFINE(XCALIBRATE, 1, [Build XCalibrate extension])
++ REQUIRED_MODULES="$REQUIRED_MODULES xcalibrateproto"
++fi
++
+ AM_CONDITIONAL(XEVIE, [test "x$XEVIE" = xyes])
+ if test "x$XEVIE" = xyes; then
+ AC_DEFINE(XEVIE, 1, [Build XEvIE extension])
+Index: git/include/kdrive-config.h.in
+===================================================================
+--- git.orig/include/kdrive-config.h.in 2007-09-08 22:17:19.000000000 +0200
++++ git/include/kdrive-config.h.in 2007-09-08 22:37:51.000000000 +0200
+@@ -31,4 +31,7 @@
+ /* Have execinfo.h for backtrace(). */
+ #undef HAVE_EXECINFO_H
+
++/* Enable XCalibrate extension */
++#undef XCALIBRATE
++
+ #endif /* _KDRIVE_CONFIG_H_ */
diff --git a/recipes/xorg-xserver/xserver-kdrive-git/w100-autofoo.patch b/recipes/xorg-xserver/xserver-kdrive-git/w100-autofoo.patch
new file mode 100644
index 0000000000..c1398093a7
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-kdrive-git/w100-autofoo.patch
@@ -0,0 +1,56 @@
+upstream: http://bugs.freedesktop.org/show_bug.cgi?id=15882
+
+Index: git/hw/kdrive/Makefile.am
+===================================================================
+--- git.orig/hw/kdrive/Makefile.am 2007-09-08 22:17:12.000000000 +0200
++++ git/hw/kdrive/Makefile.am 2007-09-08 22:40:22.000000000 +0200
+@@ -11,6 +11,10 @@
+ XFAKE_SUBDIRS = fake
+ endif
+
++if KDRIVEW100
++W100_SUBDIRS = w100
++endif
++
+ if XSDLSERVER
+ XSDL_SUBDIRS = sdl
+ endif
+@@ -26,6 +30,7 @@
+ SERVER_SUBDIRS = \
+ $(XSDL_SUBDIRS) \
+ $(FBDEV_SUBDIRS) \
++ $(W100_SUBDIRS) \
+ $(VESA_SUBDIRS) \
+ $(XEPHYR_SUBDIRS) \
+ $(XFAKE_SUBDIRS)
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2007-09-08 22:39:48.000000000 +0200
++++ git/configure.ac 2007-09-08 22:40:59.000000000 +0200
+@@ -540,6 +540,7 @@
+ AC_ARG_ENABLE(kdrive, AS_HELP_STRING([--enable-kdrive], [Build kdrive servers (default: no)]), [KDRIVE=$enableval], [KDRIVE=no])
+ AC_ARG_ENABLE(xephyr, AS_HELP_STRING([--enable-xephyr], [Build the kdrive Xephyr server (default: auto)]), [XEPHYR=$enableval], [XEPHYR=auto])
+ AC_ARG_ENABLE(xsdl, AS_HELP_STRING([--enable-xsdl], [Build the kdrive Xsdl server (default: auto)]), [XSDL=$enableval], [XSDL=auto])
++AC_ARG_ENABLE(w100, AS_HELP_STRING([--enable-w100], [Build the kdrive Xw100 server (default: no)]), [KDRIVEW100=$enableval], [KDRIVEW100=no])
+ AC_ARG_ENABLE(xfake, AS_HELP_STRING([--enable-xfake], [Build the kdrive 'fake' server (default: auto)]), [XFAKE=$enableval], [XFAKE=auto])
+ AC_ARG_ENABLE(xfbdev, AS_HELP_STRING([--enable-xfbdev], [Build the kdrive framebuffer device server (default: auto)]), [XFBDEV=$enableval], [XFBDEV=auto])
+ AC_ARG_ENABLE(kdrive-vesa, AS_HELP_STRING([--enable-kdrive-vesa], [Build the kdrive VESA-based servers (default: auto)]), [KDRIVEVESA=$enableval], [KDRIVEVESA=auto])
+@@ -1620,6 +1621,10 @@
+ fi
+ AM_CONDITIONAL(XP_USE_FREETYPE, [test "x$XPRINT" = xyes && test "x$XP_USE_FREETYPE" = xyes])
+
++AM_CONDITIONAL(KDRIVEW100, [test "x$KDRIVEW100" = xyes])
++if test "x$KDRIVEW100" = xyes; then
++ AC_DEFINE(KDRIVEW100, 1, [Build Xw100 server])
++fi
+
+ dnl XWin DDX
+
+@@ -2128,6 +2133,7 @@
+ hw/kdrive/epson/Makefile
+ hw/kdrive/fake/Makefile
+ hw/kdrive/fbdev/Makefile
++hw/kdrive/w100/Makefile
+ hw/kdrive/i810/Makefile
+ hw/kdrive/linux/Makefile
+ hw/kdrive/mach64/Makefile
diff --git a/recipes/xorg-xserver/xserver-kdrive-git/w100-post-1.4-buildfix.patch b/recipes/xorg-xserver/xserver-kdrive-git/w100-post-1.4-buildfix.patch
new file mode 100644
index 0000000000..741af64283
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-kdrive-git/w100-post-1.4-buildfix.patch
@@ -0,0 +1,12 @@
+Index: git/hw/kdrive/w100/Makefile.am
+===================================================================
+--- git.orig/hw/kdrive/w100/Makefile.am 2007-09-08 23:37:42.000000000 +0200
++++ git/hw/kdrive/w100/Makefile.am 2007-09-08 23:37:43.000000000 +0200
+@@ -46,7 +46,6 @@
+
+ Xw100_LDADD = \
+ $(W100_LIBS) \
+- @XSERVER_LIBS@ \
+ $(TSLIB_FLAG)
+
+
diff --git a/recipes/xorg-xserver/xserver-kdrive-git/xephyr-post-1.4-buildfix.patch b/recipes/xorg-xserver/xserver-kdrive-git/xephyr-post-1.4-buildfix.patch
new file mode 100644
index 0000000000..8e7cde9641
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-kdrive-git/xephyr-post-1.4-buildfix.patch
@@ -0,0 +1,11 @@
+Index: git/hw/kdrive/ephyr/ephyr_draw.c
+===================================================================
+--- git.orig/hw/kdrive/ephyr/ephyr_draw.c 2007-09-08 23:57:03.000000000 +0200
++++ git/hw/kdrive/ephyr/ephyr_draw.c 2007-09-08 23:57:13.000000000 +0200
+@@ -520,6 +520,5 @@
+ ExaScreenPriv(pScreen);
+
+ pExaScr->migration = ExaMigrationSmart;
+- pExaScr->hideOffscreenPixmapData = TRUE;
+ pExaScr->checkDirtyCorrectness = TRUE;
+ }