aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-proto
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-13 20:40:57 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-13 20:44:27 +0200
commitf2a73450a70d113d77fbf703772fbf0db81e8e61 (patch)
treec857d25a58739e515318f1880005033057a1ca16 /recipes/xorg-proto
parent5b767015541b0740a1fe47e8f435e988affa1ff7 (diff)
downloadopenembedded-f2a73450a70d113d77fbf703772fbf0db81e8e61.tar.gz
glproto, dri2proto: revert to old API until we have newer mesa
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-proto')
-rw-r--r--recipes/xorg-proto/dri2proto-2.4/f3c211e1ae183dab5c7529814c9f42af2c29fc6c.patch32
-rw-r--r--recipes/xorg-proto/dri2proto_2.4.bb4
-rw-r--r--recipes/xorg-proto/glproto-1.4.13/7196c9441af941be74180f8e8d4e10a08659b80f.patch32
-rw-r--r--recipes/xorg-proto/glproto_1.4.13.bb4
4 files changed, 70 insertions, 2 deletions
diff --git a/recipes/xorg-proto/dri2proto-2.4/f3c211e1ae183dab5c7529814c9f42af2c29fc6c.patch b/recipes/xorg-proto/dri2proto-2.4/f3c211e1ae183dab5c7529814c9f42af2c29fc6c.patch
new file mode 100644
index 0000000000..8ccae8929c
--- /dev/null
+++ b/recipes/xorg-proto/dri2proto-2.4/f3c211e1ae183dab5c7529814c9f42af2c29fc6c.patch
@@ -0,0 +1,32 @@
+From f3c211e1ae183dab5c7529814c9f42af2c29fc6c Mon Sep 17 00:00:00 2001
+From: Jesse Barnes <jbarnes@virtuousgeek.org>
+Date: Thu, 05 May 2011 16:22:39 +0000
+Subject: Revert "dri2proto: make DRI2 swap event match GLX spec"
+
+This reverts commit 0ca3778de195a82087d0f07415a1cf8fc94f5b0a.
+
+This broke compatibility by renaming existing struct fields. So revert
+in favor of a new struct.
+---
+diff --git a/dri2proto.h b/dri2proto.h
+index ff76355..9708a4a 100644
+--- a/dri2proto.h
++++ b/dri2proto.h
+@@ -290,13 +290,13 @@ typedef struct {
+ CARD8 pad;
+ CARD16 sequenceNumber B16;
+ CARD16 event_type B16;
+- CARD16 pad2;
+ CARD32 drawable B32;
+ CARD32 ust_hi B32;
+ CARD32 ust_lo B32;
+ CARD32 msc_hi B32;
+ CARD32 msc_lo B32;
+- CARD32 sbc B32;
++ CARD32 sbc_hi B32;
++ CARD32 sbc_lo B32;
+ } xDRI2BufferSwapComplete;
+ #define sz_xDRI2BufferSwapComplete 32
+
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/xorg-proto/dri2proto_2.4.bb b/recipes/xorg-proto/dri2proto_2.4.bb
index 9e95ec011d..a7a11420f9 100644
--- a/recipes/xorg-proto/dri2proto_2.4.bb
+++ b/recipes/xorg-proto/dri2proto_2.4.bb
@@ -1,6 +1,8 @@
require xorg-proto-common.inc
DESCRIPTION = "DRI2 extension headers"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+SRC_URI += "file://f3c211e1ae183dab5c7529814c9f42af2c29fc6c.patch"
SRC_URI[archive.md5sum] = "0cdeb1e95901813385dc9576be272bd3"
SRC_URI[archive.sha256sum] = "ff156f178d48ab31beeb4be5eb39d5df7540791ba489a8d94c443bb99a2376f1"
diff --git a/recipes/xorg-proto/glproto-1.4.13/7196c9441af941be74180f8e8d4e10a08659b80f.patch b/recipes/xorg-proto/glproto-1.4.13/7196c9441af941be74180f8e8d4e10a08659b80f.patch
new file mode 100644
index 0000000000..988e8e809e
--- /dev/null
+++ b/recipes/xorg-proto/glproto-1.4.13/7196c9441af941be74180f8e8d4e10a08659b80f.patch
@@ -0,0 +1,32 @@
+From 7196c9441af941be74180f8e8d4e10a08659b80f Mon Sep 17 00:00:00 2001
+From: Jesse Barnes <jbarnes@virtuousgeek.org>
+Date: Thu, 05 May 2011 16:21:19 +0000
+Subject: Revert "glxproto: make GLX swap event struct match spec"
+
+This reverts commit f5403828c68af0f12c79c0504df0a4781ca84b2b.
+
+This broke compatibility with existing code, so revert in favor of a new
+struct definition instead.
+---
+diff --git a/glxproto.h b/glxproto.h
+index dfa0647..0ff44e3 100644
+--- a/glxproto.h
++++ b/glxproto.h
+@@ -1375,13 +1375,13 @@ typedef struct {
+ BYTE pad;
+ CARD16 sequenceNumber B16;
+ CARD16 event_type B16;
+- CARD16 pad2;
+ CARD32 drawable;
+ CARD32 ust_hi B32;
+ CARD32 ust_lo B32;
+ CARD32 msc_hi B32;
+ CARD32 msc_lo B32;
+- CARD32 sbc B32;
++ CARD32 sbc_hi B32;
++ CARD32 sbc_lo B32;
+ } xGLXBufferSwapComplete;
+
+ /************************************************************************/
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/xorg-proto/glproto_1.4.13.bb b/recipes/xorg-proto/glproto_1.4.13.bb
index 04c5381324..afb35077d4 100644
--- a/recipes/xorg-proto/glproto_1.4.13.bb
+++ b/recipes/xorg-proto/glproto_1.4.13.bb
@@ -1,6 +1,8 @@
require xorg-proto-common.inc
PE = "1"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+SRC_URI += "file://7196c9441af941be74180f8e8d4e10a08659b80f.patch"
SRC_URI[archive.md5sum] = "9542f2d36751a8ad7eae9d8e176f70d4"
SRC_URI[archive.sha256sum] = "fc0a94d4df003cb6b6953173e6498d9c4c3268ee24bcc46a1172a1e1dbd3d742"