aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib/libx11_1.3.2.bb
diff options
context:
space:
mode:
authorMartin.Jansa <Martin.Jansa@gmail.com>2009-10-29 11:10:21 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-22 13:16:52 +0100
commitfba77bf1ca0257e3e795b9c514b3420fc9cf5fed (patch)
tree94e7816a6d0f78ca6771e74cde6ce9dd63df3710 /recipes/xorg-lib/libx11_1.3.2.bb
parent4a29ef0bc8969754420c94a063d32f298ab16466 (diff)
downloadopenembedded-fba77bf1ca0257e3e795b9c514b3420fc9cf5fed.tar.gz
xorg: add recipes for X11R7.5 release
* Update conf/distro/include/preferred-xorg-versions-X11R7.5.inc * Only recipe versions specified in X11R7.5 and available at http://www.x.org/releases/X11R7.5/src/
Diffstat (limited to 'recipes/xorg-lib/libx11_1.3.2.bb')
-rw-r--r--recipes/xorg-lib/libx11_1.3.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/xorg-lib/libx11_1.3.2.bb b/recipes/xorg-lib/libx11_1.3.2.bb
new file mode 100644
index 0000000000..796ed1eeb6
--- /dev/null
+++ b/recipes/xorg-lib/libx11_1.3.2.bb
@@ -0,0 +1,32 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "Base X libs."
+DEPENDS += "bigreqsproto xproto xextproto xtrans libxau xcmiscproto \
+ libxdmcp xf86bigfontproto kbproto inputproto xproto-native"
+PROVIDES = "virtual/libx11"
+PE = "1"
+PR = "r3"
+
+XORG_PN = "libX11"
+
+SRC_URI += "file://x11_disable_makekeys.1.6.3.patch;patch=1 \
+ file://dolt-fix.patch;patch=1 \
+ file://keysymdef_include.patch;patch=1"
+
+EXTRA_OECONF += "--without-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+
+do_compile() {
+ (
+ unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS
+ cd src/util;
+ mv makekeys.c.orig makekeys.c || true
+ touch makekeys-makekeys.o ; gcc makekeys.c -o makekeys
+ mv to stop it getting rebuilt
+ mv makekeys.c makekeys.c.orig
+ cd ../../
+ ) || exit 1
+ oe_runmake
+}
+
+FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${libdir}/X11/Xcms.txt"
+FILES_${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"