aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xinput-calibrator
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-31 01:44:14 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-31 02:03:08 +0100
commit48dd2427c14edb8349e9f16150ad0f9c037c2ab8 (patch)
tree33b0ba3f27b771c50b38ffb4bfdcaf6935a1bc0c /recipes/xinput-calibrator
parent538671bbb993f76abd9a756caaccaf990c696b0d (diff)
downloadopenembedded-48dd2427c14edb8349e9f16150ad0f9c037c2ab8.tar.gz
xinput-calibrator: add xinput to RDEPENDS and script to calibrate only once and store calibration data for later use
* xinput is used when we want to make the changes permanent (xinput is called with every Xorg start * xinput_calibrator_once.sh can be used from Xsession.d * calibration data are stored in /etc/pointercal.xinput * whole log from last run in /etc/pointercal.xinput.log * script needs tee and sed (busybox variants are enough) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xinput-calibrator')
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator-0.5.0/xinput_calibrator_once.sh11
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb5
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/xinput-calibrator/xinput-calibrator-0.5.0/xinput_calibrator_once.sh b/recipes/xinput-calibrator/xinput-calibrator-0.5.0/xinput_calibrator_once.sh
new file mode 100644
index 0000000000..82fcfc6570
--- /dev/null
+++ b/recipes/xinput-calibrator/xinput-calibrator-0.5.0/xinput_calibrator_once.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+if [ -e /etc/pointercal.xinput ] ; then
+ echo Using calibration data stored in /etc/pointercal.xinput
+ . /etc/pointercal.xinput
+else
+ CAL=`/usr/bin/xinput_calibrator | tee /etc/pointercal.xinput.log | grep xinput| sed 's/^ //g; s/$/;/g'`
+ if [ ! -z "$CAL" ] ; then
+ echo $CAL > /etc/pointercal.xinput
+ echo Calibration data stored in /etc/pointercal.xinput
+ fi
+fi
diff --git a/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb b/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb
index 43f77ee2a0..8390b30311 100644
--- a/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb
+++ b/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb
@@ -1,17 +1,20 @@
DEPENDS = "virtual/libx11 libxi"
+RDEPENDS = "xinput"
SRCREV = "1c715824334c5d33085dba02f195c9720c2883b5"
SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git \
file://xinput-calibrator.desktop \
+ file://xinput_calibrator_once.sh \
"
-PR = "r3"
+PR = "r4"
inherit autotools
S = "${WORKDIR}/git/"
do_install() {
install -d ${D}${bindir}
install -m 0755 src/xinput_calibrator_x11 ${D}${bindir}/xinput_calibrator
+ install -m 0755 ${WORKDIR}/xinput_calibrator_once.sh ${D}${bindir}/xinput_calibrator_once.sh
install -d ${D}${datadir}/applications/
install -m 0755 ${WORKDIR}/xinput-calibrator.desktop ${D}${datadir}/applications/xinput-calibrator.desktop
}