aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wwwoffle/wwwoffle_2.9f.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2010-02-11 22:59:30 +0000
committerutx@penguin.cz <utx@penguin.cz>2010-02-11 22:59:30 +0000
commit6172717a9c1b542ea60c5f9af62b82cd9c63c2ee (patch)
tree3ec80576fb4c54bb858ea424df12474868aaee2f /recipes/wwwoffle/wwwoffle_2.9f.bb
parent90b94b1441b9c86997e38b44e26acb3d3a56b6ec (diff)
downloadopenembedded-6172717a9c1b542ea60c5f9af62b82cd9c63c2ee.tar.gz
wwwoffle: Updated to version 2.9f.
Diffstat (limited to 'recipes/wwwoffle/wwwoffle_2.9f.bb')
-rw-r--r--recipes/wwwoffle/wwwoffle_2.9f.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/wwwoffle/wwwoffle_2.9f.bb b/recipes/wwwoffle/wwwoffle_2.9f.bb
new file mode 100644
index 0000000000..3cc96b2d15
--- /dev/null
+++ b/recipes/wwwoffle/wwwoffle_2.9f.bb
@@ -0,0 +1,30 @@
+LICENSE = "GPL"
+SECTION = "console/network"
+PRIORITY = "standard"
+DESCRIPTION = "World Wide Web Offline Explorer"
+DEPENDS = ""
+
+SRC_URI = "http://www.gedanken.demon.co.uk/download-wwwoffle/${PN}-${PV}.tgz \
+ file://wwwoffle.init \
+ file://wwwoffle.if-up \
+ file://wwwoffle.if-down"
+
+INITSCRIPT_NAME = "${PN}"
+
+inherit autotools gettext update-rc.d
+
+EXTRA_OEMAKE = "docdir=${datadir}/doc"
+
+do_configure() {
+ mv aclocal.m4 acinclude.m4
+ autotools_do_configure
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/network/if-up.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-up ${D}/${sysconfdir}/network/if-up.d/wwwoffle
+ install -d ${D}/${sysconfdir}/network/if-down.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-down ${D}/${sysconfdir}/network/if-down.d/wwwoffle
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/wwwoffle.init ${D}/${sysconfdir}/init.d/wwwoffle
+}