aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/valacompass
diff options
context:
space:
mode:
authorMichele Brocco <ssj2micvm@gmail.com>2011-02-17 22:27:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2011-02-24 09:28:49 +0100
commita47c9f3c5cf32e8db65a3b758e47ff5089c3143f (patch)
tree961e20092fdbe802342e41aa8636278449640edb /recipes/valacompass
parent6ba453f6000b1c3f9204d8c1cf879b8a90e81c3c (diff)
downloadopenembedded-a47c9f3c5cf32e8db65a3b758e47ff5089c3143f.tar.gz
valacompass: new recipe for valacompass and deps hmc5843 and lis302dl
* Works with the hmc5843 module * Calibration is required Signed-off-by: Michele Brocco <ssj2micvm@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/valacompass')
-rw-r--r--recipes/valacompass/hmc5843_git.bb20
-rw-r--r--recipes/valacompass/lis302dl_git.bb20
-rw-r--r--recipes/valacompass/valacompass_git.bb20
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes/valacompass/hmc5843_git.bb b/recipes/valacompass/hmc5843_git.bb
new file mode 100644
index 0000000000..41f286341d
--- /dev/null
+++ b/recipes/valacompass/hmc5843_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Library for easy-accessing the 3d comapss HMC5843 from Honeywell "
+AUTHOR = "Michele Brocco <ssj2micvm@gmail.com>"
+PRIORITY = "optional"
+LICENSE = "GPLv3"
+DEPENDS = "glib-2.0"
+RDEPENDS_${PN} = "glib-2.0"
+RSUGGESTS_${PN} = ""
+PV = "0.1+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://gitorious.org/sensor-monitor/libhmc5843.git;protocol=git;branch=master"
+
+SRCREV = "9cdf5141ad050c87630fe28684dbb13d93aeca46"
+S = "${WORKDIR}/git"
+
+inherit autotools vala
+
+FILES_${PN} += "${datadir}/${PN} ${datadir}/applications ${datadir}/pixmaps"
+
+MAINTAINER = "Michele Brocco <ssj2micvm@gmail.com>"
diff --git a/recipes/valacompass/lis302dl_git.bb b/recipes/valacompass/lis302dl_git.bb
new file mode 100644
index 0000000000..fc7a01c536
--- /dev/null
+++ b/recipes/valacompass/lis302dl_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Library for easy-accessing the 3d accelerometer LIS302DL from STMicroelectronics"
+AUTHOR = "Michele Brocco <ssj2micvm@gmail.com>"
+PRIORITY = "optional"
+LICENSE = "GPLv3"
+DEPENDS = "glib-2.0"
+RDEPENDS_${PN} = "glib-2.0"
+RSUGGESTS_${PN} = ""
+PV = "0.1+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://gitorious.org/sensor-monitor/liblis302dl.git;protocol=git;branch=master"
+
+SRCREV = "b5f08fc1b2ad1f01bf868a04fc8335361a9be40c"
+S = "${WORKDIR}/git"
+
+inherit autotools vala
+
+FILES_${PN} += "${datadir}/${PN} ${datadir}/applications ${datadir}/pixmaps"
+
+MAINTAINER = "Michele Brocco <ssj2micvm@gmail.com>"
diff --git a/recipes/valacompass/valacompass_git.bb b/recipes/valacompass/valacompass_git.bb
new file mode 100644
index 0000000000..97f9a3b1f0
--- /dev/null
+++ b/recipes/valacompass/valacompass_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Compass written in vala that uses the hmc5843 compass and the lis302dl accelerometer"
+AUTHOR = "Michele Brocco <ssj2micvm@gmail.com>"
+PRIORITY = "optional"
+LICENSE = "GPLv3"
+DEPENDS = "glib-2.0 gtk+ libgee cairo hmc5843 lis302dl"
+RDEPENDS_${PN} = "glib-2.0 gtk+ libgee cairo"
+RSUGGESTS_${PN} = ""
+PV = "0.1+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://gitorious.org/vala-compass/vala-compass.git;protocol=git;branch=master"
+
+SRCREV = "0214a81c6ab3d8604233588ae5727b851fde236d"
+S = "${WORKDIR}/git"
+
+inherit autotools vala
+
+FILES_${PN} += "${datadir}/${PN} ${datadir}/applications ${datadir}/pixmaps"
+
+MAINTAINER = "Michele Brocco <ssj2micvm@gmail.com>"