aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/util-linux-ng
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-04 11:47:54 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-04 12:14:10 -0700
commit4675f6234ce0fb9ad3dcbb044aacef4e98b17c6a (patch)
treeb2ba24c31b78ba2dfec4eecac0f1523ba2521f72 /recipes/util-linux-ng
parent2ae0257100a201a961092e4e3bd2bd5d020f4bb2 (diff)
downloadopenembedded-4675f6234ce0fb9ad3dcbb044aacef4e98b17c6a.tar.gz
util-linux-ng: Clean up native config bits.
We don't need the ncurses stuff for how we use this, so disable it (and bump INC_PR). In util-linux-ng_2.17.bb the override to add some bits to the native recipe was killing all of the other parts so change the syntax so it doesn't, and set PR=INC_PR (now that INC_PR is bumped). Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/util-linux-ng')
-rw-r--r--recipes/util-linux-ng/util-linux-ng.inc9
-rw-r--r--recipes/util-linux-ng/util-linux-ng_2.17.bb4
2 files changed, 8 insertions, 5 deletions
diff --git a/recipes/util-linux-ng/util-linux-ng.inc b/recipes/util-linux-ng/util-linux-ng.inc
index fa367d9a70..29e534c148 100644
--- a/recipes/util-linux-ng/util-linux-ng.inc
+++ b/recipes/util-linux-ng/util-linux-ng.inc
@@ -2,11 +2,11 @@ DESCRIPTION = "Util-linux-ng is a suite of essential utilities for any Linux sys
SECTION = "base"
LICENSE = "GPL"
DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} udev zlib ncurses virtual/libintl"
-DEPENDS_virtclass-native = "zlib-native ncurses-native lzo-native gettext-native"
+DEPENDS_virtclass-native = "zlib-native lzo-native gettext-native"
inherit autotools gettext
-INC_PR = "r34"
+INC_PR = "r35"
# allows for a release candidate
RC ?= ""
@@ -65,11 +65,14 @@ RDEPENDS_${PN}-reset = "ncurses-tools"
RRECOMMENDS_${PN}_virtclass-native = ""
RDEPENDS_${PN}_virtclass-native = ""
+NATIVECONF = ""
+NATIVECONF_virtclass-native = "--without-ncurses"
+
EXTRA_OECONF = "--disable-use-tty-group --disable-makeinstall-chown \
--enable-kill --enable-last --enable-mesg --enable-raw --enable-login-utils \
--enable-arch --enable-init --enable-partx --enable-schedutils \
--with-fsprobe=builtin --enable-libuuid --enable-libblkid \
---enable-fsck --enable-reset"
+--enable-fsck --enable-reset ${NATIVECONF}"
LDFLAGS_append_libc-uclibc = "${@['',' -lintl'][bb.data.getVar('USE_NLS', d, 1) == 'yes']}"
LDFLAGS_virtclass-native = "${BUILD_LDFLAGS}"
diff --git a/recipes/util-linux-ng/util-linux-ng_2.17.bb b/recipes/util-linux-ng/util-linux-ng_2.17.bb
index 8b4b1c9940..dfcc15c213 100644
--- a/recipes/util-linux-ng/util-linux-ng_2.17.bb
+++ b/recipes/util-linux-ng/util-linux-ng_2.17.bb
@@ -1,6 +1,6 @@
require util-linux-ng.inc
-PR = "${INC_PR}.3"
+PR = "${INC_PR}"
SRC_URI += "file://uclibc-compile.patch \
file://util-linux-ng-replace-siginterrupt.patch \
@@ -11,7 +11,7 @@ SRC_URI += "file://uclibc-compile.patch \
# fallocate is glibc 2.10, fallocate64 is glibc 2.11
# we need to disable it for older versions
EXTRA_OECONF += "ac_cv_func_fallocate=no"
-EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"
+EXTRA_OECONF_append_virtclass-native += "--disable-fallocate --disable-use-tty-group"
SRC_URI[archive.md5sum] = "11cc8a0138019e7060dd275d47dbc096"
SRC_URI[archive.sha256sum] = "8720f7233394b68d17095707c195ebb014943c1075a18fb5fd21ec108f012be3"