aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udev/udev_151.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-10-13 13:32:23 -0700
committerTom Rini <tom_rini@mentor.com>2010-10-13 13:35:13 -0700
commit278fe3bc04b4a0d31ba080d7b43c72a6a09fb70a (patch)
tree1e127c8aefe156e30906c8e2c20ab9110b09adc6 /recipes/udev/udev_151.bb
parent9ac50f2494f029df76176117cb77a21491194855 (diff)
downloadopenembedded-278fe3bc04b4a0d31ba080d7b43c72a6a09fb70a.tar.gz
udev 141/151/154: Fix update-rc.d logic for udev-cache
The way that functions are evaluated means that while we say append our update-rc.d addition for udev-cache ends up at the top of the postinst script meaning that $OPT is not set and this error will cause no udev rcN.d symlinks to be created until during the first boot which can be a problem. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/udev/udev_151.bb')
-rw-r--r--recipes/udev/udev_151.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/udev/udev_151.bb b/recipes/udev/udev_151.bb
index d6a858d973..fc33592442 100644
--- a/recipes/udev/udev_151.bb
+++ b/recipes/udev/udev_151.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r17"
+PR = "r18"
# Untested
DEFAULT_PREFERENCE = "-1"
@@ -147,6 +147,11 @@ do_install_append_bug() {
# Create the cache after checkroot has run
pkg_postinst_udev_append() {
+ if test "x$D" != "x"; then
+ OPT="-r $D"
+ else
+ OPT="-s"
+ fi
update-rc.d $OPT udev-cache start 12 S .
}