aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tracker/tracker_0.6.95.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-03 21:05:49 +0000
committerKoen Kooi <koen@openembedded.org>2009-11-07 19:17:52 +0100
commit252dc53aa97d3f284078b7d89a9f6b7792ce7466 (patch)
tree8967e45055ae0725c834eb3d44e92d6af123904c /recipes/tracker/tracker_0.6.95.bb
parent6e04e09b03bd934cbbe62079732318d1713164a5 (diff)
downloadopenembedded-252dc53aa97d3f284078b7d89a9f6b7792ce7466.tar.gz
tracker: Add 0.6.95 release and series of patches to support cross compile. (WIP)
Diffstat (limited to 'recipes/tracker/tracker_0.6.95.bb')
-rw-r--r--recipes/tracker/tracker_0.6.95.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/tracker/tracker_0.6.95.bb b/recipes/tracker/tracker_0.6.95.bb
new file mode 100644
index 0000000000..f97b5ea881
--- /dev/null
+++ b/recipes/tracker/tracker_0.6.95.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Tracker is a tool designed to extract information and metadata about your personal data so that it can be searched easily and quickly."
+LICENSE = "GPLv2"
+DEPENDS = "file gtk+ gstreamer gamin libgmime dbus poppler libexif libgsf libgnomecanvas gettext"
+HOMEPAGE="http://www.tracker-project.org/"
+
+PR = "r1"
+
+inherit autotools pkgconfig gnome
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/tracker-${PV}.tar.bz2 \
+ file://munge-configure.ac-cross-compile.patch;patch=1 \
+ file://05-tracker-ioprio-cross.patch;patch=1 \
+ file://10-drop-bogus-version-info.patch;patch=1 \
+ file://20-tracker-defaults.patch;patch=1 \
+ file://30-gmime-2.4.patch;patch=1 \
+ file://99-autoreconf.patch;patch=1 \
+ file://90tracker \
+"
+
+EXTRA_OECONF += " tracker_cv_have_ioprio=yes"
+
+LEAD_SONAME = "libtrackerclient.so.0"
+
+do_install_append() {
+ cp -dPr ${D}${STAGING_DATADIR}/* ${D}${datadir}/ || true
+ install -d ${D}/${sysconfdir}/X11/Xsession.d/
+ install -m 0755 ${WORKDIR}/90tracker ${D}/${sysconfdir}/X11/Xsession.d/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/dbus-1/"
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"
+
+CONFFILES_${PN} += "${sysconfdir}/X11/Xsession.d/90tracker"