aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcltk
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2011-04-20 19:55:49 +0000
committerutx@penguin.cz <utx@penguin.cz>2011-04-20 20:02:19 +0000
commit7c4aeaf7e2a2b96e700cd5230b0e7b415ab08eab (patch)
tree394f897303b0078507583c151fa27b1d47c2915c /recipes/tcltk
parent38058be0f8d5f6badd9116ed00f1b99f71347cc8 (diff)
downloadopenembedded-7c4aeaf7e2a2b96e700cd5230b0e7b415ab08eab.tar.gz
tcl: Adapt tclConfig.sh modification to binconfig.class change.
Signed-off-by: Stanislav Brabec <utx@penguin.cz>
Diffstat (limited to 'recipes/tcltk')
-rw-r--r--recipes/tcltk/tcl_8.5.8.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/recipes/tcltk/tcl_8.5.8.bb b/recipes/tcltk/tcl_8.5.8.bb
index 9bb6859434..82bc1bfe48 100644
--- a/recipes/tcltk/tcl_8.5.8.bb
+++ b/recipes/tcltk/tcl_8.5.8.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Tool Command Language"
HOMEPAGE = "http://tcl.sourceforge.net"
SECTION = "devel/tcltk"
LICENSE = "tcl"
-PR = "r8"
+PR = "r9"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz \
@@ -33,8 +33,7 @@ do_compile_prepend_pn-tcl () {
sed -i -e 's:./tclsh :tclsh :g' Makefile
}
-do_install() {
- autotools_do_install
+do_install_append() {
# Stage a few extra headers to make tk happy
install -d ${D}${includedir}/tcl-${PV}/generic
install -m 0644 ../generic/*.h ${D}${includedir}/tcl-${PV}/generic
@@ -43,6 +42,9 @@ do_install() {
install -m 0644 *Unix*.h ${D}${includedir}/tcl-${PV}/unix/
rm -f ${D}${includedir}/regex.h
ln -sf tclsh8.5 ${D}${bindir}/tclsh
+ # trick: We set it to incorrect value but binconfig will fix it
+ # correctly for both target and staging package.
+ sed -i 's:${includedir}/tcl-private:${STAGING_INCDIR}/tcl-${PV}:' ${D}${libdir}/tclConfig.sh
}
PACKAGES =+ "${PN}-lib"
@@ -53,8 +55,3 @@ FILES_${PN}-dev += "${libdir}/tclConfig.sh"
BINCONFIG_GLOB = "*Config.sh"
BBCLASSEXTEND = "native"
-
-tcl_sysroot() {
- sed -i 's:${includedir}/tcl-private:${STAGING_INCDIR}/tcl-${PV}:' tclConfig.sh
-}
-