aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-16 09:53:07 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-16 22:21:23 +0200
commitf4d615ceefe868dd4687cdb23848028c307ec23b (patch)
treeb25d914bacc6572d8effc479294b6f9a837933d6 /recipes/tasks
parent1e255fbd296e95ff178d66c4a1fe4875a988d7e1 (diff)
downloadopenembedded-f4d615ceefe868dd4687cdb23848028c307ec23b.tar.gz
task-base: make it possible for a distro to set it's alsa-state provider
There different recipes in OE which provides alsa-state. In my case it's alsa-state and fsoaudiod which conflicts as both are mostly the same. For this I added a DISTRO_ALSA_STATE variable which each distro can set on it's own the provider of alsa-state it want to use. The default provider is the alsa-state recipe. Signed-off-by: Simon Busch <morphis@gravedo.de> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-base.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index 225258fb10..fdb0fb5628 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r95"
+PR = "r96"
inherit task
@@ -63,6 +63,9 @@ DISTRO_SSH_DAEMON ?= "dropbear"
# Distro can override apm provider
DISTRO_APM ?= "apm"
+# Distro can override alsa-state provider
+DISTRO_ALSA_STATE ?= "alsa-state"
+
#
# bluetooth manager
#
@@ -219,7 +222,7 @@ RDEPENDS_task-base-alsa = "\
# alsa-states are machine related so can be missing in feed, OSS support is optional
#
RRECOMMENDS_task-base-alsa = "\
- alsa-state \
+ ${DISTRO_ALSA_STATE} \
kernel-module-snd-mixer-oss \
kernel-module-snd-pcm-oss"