aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/systemd
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-05-11 08:58:54 +0200
committerKoen Kooi <koen@openembedded.org>2011-05-11 09:00:42 +0200
commitc8f9f1a7dd6e083f1e3b44a2ea2c1736c9645b4b (patch)
tree679cc573b7929d2994e957fed5adc8dd7cd7d208 /recipes/systemd
parent76e71325ea4da1de9d828dc1a35c26f67e5878d7 (diff)
downloadopenembedded-c8f9f1a7dd6e083f1e3b44a2ea2c1736c9645b4b.tar.gz
systemd v26: remove accept patch, we really want accept4
also add patch to add extra info to systemd-analyze plots Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/systemd')
-rw-r--r--recipes/systemd/systemd-v26/0002-systemd-analyze-print-hostname-kernelversion-and-arc.patch36
-rw-r--r--recipes/systemd/systemd-v26/replace_accpet4.patch26
-rw-r--r--recipes/systemd/systemd_git.bb4
3 files changed, 38 insertions, 28 deletions
diff --git a/recipes/systemd/systemd-v26/0002-systemd-analyze-print-hostname-kernelversion-and-arc.patch b/recipes/systemd/systemd-v26/0002-systemd-analyze-print-hostname-kernelversion-and-arc.patch
new file mode 100644
index 0000000000..fad0134ef5
--- /dev/null
+++ b/recipes/systemd/systemd-v26/0002-systemd-analyze-print-hostname-kernelversion-and-arc.patch
@@ -0,0 +1,36 @@
+From 59c95610fe9601091807a089a463607bd0a01f24 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 10 May 2011 20:27:29 +0200
+Subject: [PATCH 2/2] systemd-analyze: print hostname, kernelversion and arch at the top of the plot
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ src/systemd-analyze | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/src/systemd-analyze b/src/systemd-analyze
+index 4f3e478..ae7dcfb 100755
+--- a/src/systemd-analyze
++++ b/src/systemd-analyze
+@@ -110,7 +110,7 @@ elif sys.argv[1] == 'blame':
+ sys.stdout.write("%6lums %s\n" % ((aet - ixt) / 1000, name))
+
+ elif sys.argv[1] == 'plot':
+- import cairo
++ import cairo, os
+
+ initrd_time, start_time, finish_time = acquire_start_time()
+ data = acquire_time_data()
+@@ -160,6 +160,9 @@ elif sys.argv[1] == 'plot':
+ context.stroke()
+ context.restore()
+
++ banner = "Running on %s (%s %s) %s" % (os.uname()[1], os.uname()[2], os.uname()[3], os.uname()[4])
++ draw_text(context, 0, -15, banner, hcenter = 0, vcenter = 1)
++
+ for x in range(0, (finish_time - start_time)/10000, 100):
+ draw_text(context, x, -5, "%lus" % (x/100), vcenter = 0, hcenter = 0)
+
+--
+1.6.6.1
+
diff --git a/recipes/systemd/systemd-v26/replace_accpet4.patch b/recipes/systemd/systemd-v26/replace_accpet4.patch
deleted file mode 100644
index d57b07af65..0000000000
--- a/recipes/systemd/systemd-v26/replace_accpet4.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: git/src/logger.c
-===================================================================
---- git.orig/src/logger.c 2010-06-15 23:02:38.212932153 +0200
-+++ git/src/logger.c 2010-06-15 23:02:51.091686447 +0200
-@@ -331,7 +331,7 @@
-
- assert(s);
-
-- if ((fd = accept4(server_fd, NULL, NULL, SOCK_NONBLOCK|SOCK_CLOEXEC)) < 0)
-+ if ((fd = accept(server_fd, NULL, NULL)) < 0)
- return -errno;
-
- if (s->n_streams >= STREAMS_MAX) {
-Index: git/src/socket.c
-===================================================================
---- git.orig/src/socket.c 2010-06-15 23:02:16.269606647 +0200
-+++ git/src/socket.c 2010-06-15 23:02:31.115021717 +0200
-@@ -1201,7 +1201,7 @@
- if (w->socket_accept) {
- for (;;) {
-
-- if ((cfd = accept4(fd, NULL, NULL, SOCK_NONBLOCK)) < 0) {
-+ if ((cfd = accept(fd, NULL, NULL)) < 0) {
-
- if (errno == EINTR)
- continue;
diff --git a/recipes/systemd/systemd_git.bb b/recipes/systemd/systemd_git.bb
index 6688eed7c6..52e37470a3 100644
--- a/recipes/systemd/systemd_git.bb
+++ b/recipes/systemd/systemd_git.bb
@@ -10,7 +10,7 @@ PRIORITY = "optional"
SECTION = "base/shell"
PV = "v26"
-PR = "r8"
+PR = "r9"
PR_append = "+${SRCPV}"
inherit autotools vala update-alternatives
@@ -20,8 +20,8 @@ TAG = "7a6000a68241d23c9f6f6bde47b2cfa9c18189da"
SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git;tag=${TAG} \
file://execute.patch \
file://0001-systemd-disable-xml-file-stuff-and-introspection.patch \
+ file://0002-systemd-analyze-print-hostname-kernelversion-and-arc.patch \
file://0003-Angstrom-support.patch \
- file://replace_accpet4.patch \
file://serial-getty@.service \
"