aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/stopwatch
diff options
context:
space:
mode:
authorChristian Rüb <christian.rueb@gmx.net>2010-02-01 17:33:39 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-02 01:52:04 +0100
commitad31cefddc85e805305af5763a07f3495cb38bba (patch)
tree9356a2189f71fb10866541a7260cde3a8b24a350 /recipes/stopwatch
parentb7802933626b9bae65f06888ce1ba6f008f60d0c (diff)
downloadopenembedded-ad31cefddc85e805305af5763a07f3495cb38bba.tar.gz
stopwatch: Add version 1.4.0
* use tarball not git for source * preferred version is not git Signed-off-by: Christian Rüb <christian.rueb@gmx.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/stopwatch')
-rw-r--r--recipes/stopwatch/stopwatch_1.4.0.bb33
-rw-r--r--recipes/stopwatch/stopwatch_git.bb4
2 files changed, 35 insertions, 2 deletions
diff --git a/recipes/stopwatch/stopwatch_1.4.0.bb b/recipes/stopwatch/stopwatch_1.4.0.bb
new file mode 100644
index 0000000000..91a19486b6
--- /dev/null
+++ b/recipes/stopwatch/stopwatch_1.4.0.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Simple Qt based stop watch"
+AUTHOR = "Christof Musik"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+HOMEPAGE = "http://git.senfdax.de"
+LICENSE = "GPL QPL"
+PR = "r0"
+
+inherit qt4x11
+
+SRC_URI = "http://openmoko.senfdax.de/sources/${PN}-${PV}.tar.gz;name=archive"
+
+SRC_URI[archive.md5sum] = "6cc756ea7a8fb94352eb2842d170f16c"
+SRC_URI[archive.sha256sum] = "ef4fdbb3ab44e950a56c55e38dd5ffc449f736fb5d99d2befe5bbfc715bcb919"
+
+do_configure() {
+ ${OE_QMAKE_QMAKE}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/stopwatch ${D}/${bindir}
+ install -d ${D}/${datadir}/applications
+ install ${S}/desktop/stopwatch.desktop ${D}/${datadir}/applications/
+ install -d ${D}/${datadir}/pixmaps
+ install ${S}/desktop/stopwatch.png ${D}/${datadir}/pixmaps/
+ install -d ${D}/${datadir}/${PN}
+ install ${S}/desktop/om.style ${D}/${datadir}/${PN}/
+}
diff --git a/recipes/stopwatch/stopwatch_git.bb b/recipes/stopwatch/stopwatch_git.bb
index f0d40da54b..0732f56ef0 100644
--- a/recipes/stopwatch/stopwatch_git.bb
+++ b/recipes/stopwatch/stopwatch_git.bb
@@ -4,13 +4,13 @@ SECTION = "x11/applications"
PRIORITY = "optional"
HOMEPAGE = "http://git.senfdax.de"
LICENSE = "GPL QPL"
-DEPENDS = "qt4-x11-free"
+DEFAULT_PREFERRENCE = "-1"
PV = "1.3.1+gitr${SRCREV}"
PR = "r0"
inherit qt4x11
-SRC_URI = "git://git.senfdax.de/git/stopwatch;protocol=http;tag=master;branch=master"
+SRC_URI = "git://git.senfdax.de/git/stopwatch;protocol=http"
S = "${WORKDIR}/git/"
do_configure() {