aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/samba
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-10-12 06:52:33 -0700
committerTom Rini <tom_rini@mentor.com>2010-10-12 06:58:34 -0700
commit0946177ef3e91cbb6dd1c62063911a2bb68d3c4f (patch)
treeb109a46d9566e8db07a49d9c6c8a29f1263ba84b /recipes/samba
parenta5d76edf3216eed8c8710b0b639499cd7ade21ab (diff)
downloadopenembedded-0946177ef3e91cbb6dd1c62063911a2bb68d3c4f.tar.gz
samba, samba-ads: Update to 3.5.6 for security fixes
There's a large number of issues fixed over 3.3.9 (and even more over the older versions) here. Still D_P = -1 for the tdb thing but if your distro was on 3.3.x 3.5.6 should be a safe upgrade. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/samba')
-rw-r--r--recipes/samba/samba-ads_3.5.6.bb18
-rw-r--r--recipes/samba/samba_3.5.6.bb43
2 files changed, 61 insertions, 0 deletions
diff --git a/recipes/samba/samba-ads_3.5.6.bb b/recipes/samba/samba-ads_3.5.6.bb
new file mode 100644
index 0000000000..1119c1b4a5
--- /dev/null
+++ b/recipes/samba/samba-ads_3.5.6.bb
@@ -0,0 +1,18 @@
+require samba.inc
+require samba-ads.inc
+LICENSE = "GPLv3"
+
+PR = "r3"
+SRC_URI += "file://config-lfs.patch \
+ file://quota.patch;striplevel=0 \
+ file://configure-3.3.0.patch \
+ file://config-h.patch \
+ file://mtab.patch \
+ "
+
+do_compile () {
+ base_do_compile
+}
+
+SRC_URI[md5sum] = "bf6c09ea497a166df8bd672db1d8da8f"
+SRC_URI[sha256sum] = "466410868375d19a286ac3fc5d9f3c267ce359189f8e0d76e72ec10bd54247da"
diff --git a/recipes/samba/samba_3.5.6.bb b/recipes/samba/samba_3.5.6.bb
new file mode 100644
index 0000000000..72bada9286
--- /dev/null
+++ b/recipes/samba/samba_3.5.6.bb
@@ -0,0 +1,43 @@
+require samba.inc
+require samba-basic.inc
+LICENSE = "GPLv3"
+S = "${WORKDIR}/samba-${PV}/source3"
+
+# 3.3.0 and newer will upgrade your tdb database to a
+# new version that you can not downgrade to use with older
+# releases. More testing will happen before this is removed
+# should there be further issues. Appears to work though :)
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "file://config-h.patch \
+ file://tdbheaderfix.patch;apply=no"
+
+PR = "r0"
+
+EXTRA_OECONF += "\
+ SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+ samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
+ linux_getgrouplist_ok=no \
+ samba_cv_HAVE_BROKEN_GETGROUPS=no \
+ samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
+ samba_cv_have_setresuid=yes \
+ samba_cv_have_setresgid=yes \
+ samba_cv_HAVE_WRFILE_KEYTAB=yes \
+ samba_cv_linux_getgrouplist_ok=yes \
+ "
+
+do_configure() {
+ # Patches we must apply by hand due to layout.
+ cd ..
+ patch -p1 -i ${WORKDIR}/tdbheaderfix.patch
+ cd source3
+
+ oe_runconf
+}
+
+do_compile () {
+ base_do_compile
+}
+
+SRC_URI[md5sum] = "bf6c09ea497a166df8bd672db1d8da8f"
+SRC_URI[sha256sum] = "466410868375d19a286ac3fc5d9f3c267ce359189f8e0d76e72ec10bd54247da"