aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rpm/files
diff options
context:
space:
mode:
authorStanislav Brabec <sbrabec@suse.cz>2009-03-20 14:09:16 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-03-20 14:09:16 +0000
commita2f5dab7c85c1711e3c88d34c4a8254f47aae96e (patch)
treeb6075cdc2deaf54e14479aed0d2ed7e92fb646dc /recipes/rpm/files
parent899f35e8f71271de177f81cb470b9e87965107f2 (diff)
downloadopenembedded-a2f5dab7c85c1711e3c88d34c4a8254f47aae96e.tar.gz
rpm: Fixed build if libdir != prefix/lib.
Diffstat (limited to 'recipes/rpm/files')
-rw-r--r--recipes/rpm/files/rpmconfigdir.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/rpm/files/rpmconfigdir.patch b/recipes/rpm/files/rpmconfigdir.patch
new file mode 100644
index 0000000000..24f884c9f0
--- /dev/null
+++ b/recipes/rpm/files/rpmconfigdir.patch
@@ -0,0 +1,27 @@
+Index: rpm-4.4.2.3/Makefile.am
+===================================================================
+--- rpm-4.4.2.3.orig/Makefile.am 2009-03-18 17:12:48.000000000 +0000
++++ rpm-4.4.2.3/Makefile.am 2009-03-18 17:32:34.000000000 +0000
+@@ -122,14 +122,14 @@
+
+ install-data-local:
+ @$(mkinstalldirs) $(DESTDIR)$(varprefix)/lib/rpm
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpmt
+- @@LN_S@ rpmb $(DESTDIR)$(libdir)/rpm/rpmt
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpme
+- @@LN_S@ rpmi $(DESTDIR)$(libdir)/rpm/rpme
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpmu
+- @@LN_S@ rpmi $(DESTDIR)$(libdir)/rpm/rpmu
+- @rm -f $(DESTDIR)$(libdir)/rpm/rpmv
+- @@LN_S@ rpmq $(DESTDIR)$(libdir)/rpm/rpmv
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpmt
++ @@LN_S@ rpmb $(DESTDIR)@RPMCONFIGDIR@/rpmt
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpme
++ @@LN_S@ rpmi $(DESTDIR)@RPMCONFIGDIR@/rpme
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpmu
++ @@LN_S@ rpmi $(DESTDIR)@RPMCONFIGDIR@/rpmu
++ @rm -f $(DESTDIR)@RPMCONFIGDIR@/rpmv
++ @@LN_S@ rpmq $(DESTDIR)@RPMCONFIGDIR@/rpmv
+ rm -f $(DESTDIR)$(bindir)/rpmbuild
+ @LN_S@ ../lib/rpm/rpmb $(DESTDIR)$(bindir)/rpmbuild
+ rm -f $(DESTDIR)$(bindir)/rpmquery