aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qwo
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2009-03-22 09:57:20 -0400
committerPhilip Balister <philip@balister.org>2009-03-22 10:02:29 -0400
commit3ec6fa5f0b312f7d1be9e0a8d7f587591834d5e5 (patch)
tree1f0874fb74341da541e7f16f7c743a2612d3b71f /recipes/qwo
parent9429a8e008563531656b6bdd9be7ec365cd18b1b (diff)
downloadopenembedded-3ec6fa5f0b312f7d1be9e0a8d7f587591834d5e5.tar.gz
qwo : Add new recipe for qwo.
* qwo is an input method for text on hand-held devices.
Diffstat (limited to 'recipes/qwo')
-rw-r--r--recipes/qwo/qwo-0.4/check_lib.patch20
-rw-r--r--recipes/qwo/qwo_0.4.bb16
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/qwo/qwo-0.4/check_lib.patch b/recipes/qwo/qwo-0.4/check_lib.patch
new file mode 100644
index 0000000000..c22ec20312
--- /dev/null
+++ b/recipes/qwo/qwo-0.4/check_lib.patch
@@ -0,0 +1,20 @@
+diff --git a/configure.ac b/configure.ac
+index 8a66f96..61063a9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,15 +19,7 @@ AC_CHECK_LIB(config, config_read)
+
+ dnl Check for imlib2 library
+
+-AC_PATH_PROG(IMLIB2_CONFIG, imlib2-config, no)
+-
+-if test "$IMLIB2_CONFIG" = "no" ; then
+- AC_MSG_ERROR([
+-*** Unable to find Imlib2 library.])
+-else
+- CFLAGS="$CFLAGS `$IMLIB2_CONFIG --cflags`"
+- LIBS="$LIBS `$IMLIB2_CONFIG --libs`"
+-fi
++AC_CHECK_LIB(Imlib2, imlib_create_image)
+
+ dnl Check for help2man
diff --git a/recipes/qwo/qwo_0.4.bb b/recipes/qwo/qwo_0.4.bb
new file mode 100644
index 0000000000..03ce7d6a88
--- /dev/null
+++ b/recipes/qwo/qwo_0.4.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "qwo virtual keyboard"
+AUTHOR = "Charles Clement"
+HOMEPAGE = "http://www.nongnu.org/qwo/"
+SECTION = "x11"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "libxtst libxext virtual/imlib2 libconfig"
+RDEPENDS += "imlib2-loaders"
+PV = "0.4"
+PR = "r0"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/qwo/qwo-${PV}.tar.gz \
+ file://check_lib.patch;patch=1 \
+ "
+
+inherit autotools