aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-23 18:50:04 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-23 18:53:18 +0200
commitc1d2cab4a0b95a77822766ca28820ca4aede23a4 (patch)
tree6633ab6afacc6e2308b97e45044886bafd783b88 /recipes/qt4/qt4-x11-free-gles_git.bb.disabled
parent21ccb58d1af2eef804941391ab780444aa98adf5 (diff)
downloadopenembedded-c1d2cab4a0b95a77822766ca28820ca4aede23a4.tar.gz
qt*gles: rename to .disabled till the qt4 stuff becomes less magical
Diffstat (limited to 'recipes/qt4/qt4-x11-free-gles_git.bb.disabled')
-rw-r--r--recipes/qt4/qt4-x11-free-gles_git.bb.disabled40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-x11-free-gles_git.bb.disabled b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
new file mode 100644
index 0000000000..d5474a8f8b
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
@@ -0,0 +1,40 @@
+# recipe to build GLES gfxdriver
+
+FILESPATHPKG =. "qt4-x11-free-${PV}:qt4-x11-free:"
+
+QT_GLFLAGS = "-opengl es1 -openvg"
+
+include qt4-x11-free.inc
+LICENSE += "LGPL"
+PR = "${INC_PR}.0+gitr${SRCREV}"
+
+DEPENDS += "virtual/egl"
+
+SRCREV = "b11f173"
+SRC_URI = "git://git.gitorious.org/qt/qt.git;protocol=http \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0007-openssl-host-includes.patch;patch=1 \
+ file://0008-qt-lib-infix.patch;patch=1 \
+ file://g++.conf \
+ file://linux.conf \
+ "
+#SRC_URI += "file://sgx-hack.patch;patch=1"
+
+S = "${WORKDIR}/git"
+
+export EXTRA_QMAKE_MUNGE = " glmunge "
+
+glmunge() {
+sed -e /QMAKE_INCDIR_OPENGL/d -e /QMAKE_LIBDIR_OPENGL/d -e /QMAKE_LIBS_OPENGL/d -e /QMAKE_LIBS_OPENGL_QT/d -i mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_INCDIR_OPENGL = ${STAGING_INCDIR}/GLES/" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_LIBDIR_OPENGL = ${STAGING_LIBDIR}" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_LIBS_OPENGL = -lEGL -lGLES_CM -lIMGegl -lsrv_um -lOpenVG" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+echo "QMAKE_LIBS_OPENGL_QT = -lEGL -lGLES_CM -lIMGegl -lsrv_um -lOpenVG" >> mkspecs/${OE_QMAKE_PLATFORM}/qmake.conf
+}
+
+
+