aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qmake/qmake2_2.10a.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-10 11:32:28 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-14 11:28:40 +0100
commit3d45480a1cf1ac4d554434699365306c7f09c6cc (patch)
tree457e6afb85f4e7b1a25e8c4b72f1a060c5766a4e /recipes/qmake/qmake2_2.10a.bb
parentb6a63dbf5a87845bab6ce774277bc3287b4d9a89 (diff)
downloadopenembedded-3d45480a1cf1ac4d554434699365306c7f09c6cc.tar.gz
qmake2: convert native and sdk to use BBCLASS_EXTEND and new-style staging
Diffstat (limited to 'recipes/qmake/qmake2_2.10a.bb')
-rw-r--r--recipes/qmake/qmake2_2.10a.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/qmake/qmake2_2.10a.bb b/recipes/qmake/qmake2_2.10a.bb
new file mode 100644
index 0000000000..abf4380b7c
--- /dev/null
+++ b/recipes/qmake/qmake2_2.10a.bb
@@ -0,0 +1,18 @@
+QTVERSION="4.4.3"
+FILESDIR += "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/qmake2"
+
+BBCLASSEXTEND = "native sdk"
+
+require ${PN}.inc
+
+SRC_URI += "file://qmake-hack.diff;patch=1"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 bin/qmake ${D}/${bindir}/qmake2
+ install -m 0755 bin/qmake ${D}/${bindir}/qmake-qt4
+ install -d ${D}/${datadir}/qt4
+ cp -PfR mkspecs ${D}/${datadir}/qt4/
+}
+
+