aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-native_2.7.1.bb
diff options
context:
space:
mode:
authorBen Gamari <bgamari.foss@gmail.com>2010-12-28 02:59:45 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-07 14:42:31 -0800
commit412ab1b8234785f3c19f545bd5041b74169b167f (patch)
treef360387ce155ea91e27422a7ed778608e0dc200a /recipes/python/python-native_2.7.1.bb
parentc65ccdbe7c6f5c283a31b182931cddb5aa07fcd0 (diff)
downloadopenembedded-412ab1b8234785f3c19f545bd5041b74169b167f.tar.gz
python: Initial commit of python 2.7.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python/python-native_2.7.1.bb')
-rw-r--r--recipes/python/python-native_2.7.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/python/python-native_2.7.1.bb b/recipes/python/python-native_2.7.1.bb
new file mode 100644
index 0000000000..eb487a99a4
--- /dev/null
+++ b/recipes/python/python-native_2.7.1.bb
@@ -0,0 +1,38 @@
+require python2.7.inc
+DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
+PR = "${INC_PR}.1"
+
+FILESPATHPKG .= ":python-${PV}:python"
+SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
+ file://04-default-is-optimized.patch \
+ file://05-enable-ctypes-cross-build.patch \
+ file://06-ctypes-libffi-fix-configure.patch \
+ file://10-distutils-fix-swig-parameter.patch \
+ file://11-distutils-never-modify-shebang-line.patch \
+ file://12-distutils-prefix-is-inside-staging-area.patch \
+ file://debug.patch \
+ file://nohostlibs.patch"
+SRC_URI[md5sum] = "aa27bc25725137ba155910bd8e5ddc4f"
+SRC_URI[sha256sum] = "80e387bcf57eae8ce26726753584fd63e060ec11682d1145af921e85fd612292"
+
+S = "${WORKDIR}/Python-${PV}"
+
+inherit native
+
+EXTRA_OECONF_append = '\
+ --enable-unicode=ucs4 \
+'
+
+EXTRA_OEMAKE = '\
+ BUILD_SYS="" \
+ HOST_SYS="" \
+ LIBC="" \
+ STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
+ STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
+'
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${bindir}/
+ install -m 0755 Parser/pgen ${D}${bindir}/
+}