aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-lxml_2.2.6.bb
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-04-08 12:16:56 +0200
committerMichael Lippautz <michael.lippautz@gmail.com>2010-04-08 12:16:56 +0200
commit163489ebbfd592252adec0c11006aa9ab3915c13 (patch)
tree7502eaf247cc1f59466a1ad436683c9cf85690c9 /recipes/python/python-lxml_2.2.6.bb
parent826a4c44f9f87c65906d1e29ed2ce28c1762213b (diff)
downloadopenembedded-163489ebbfd592252adec0c11006aa9ab3915c13.tar.gz
python-lxml: Fix recipe.
* Use latest version * Remove nonworking copy and unused patch * Move recipe to python/ dir Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
Diffstat (limited to 'recipes/python/python-lxml_2.2.6.bb')
-rw-r--r--recipes/python/python-lxml_2.2.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/python/python-lxml_2.2.6.bb b/recipes/python/python-lxml_2.2.6.bb
new file mode 100644
index 0000000000..93280f1fb4
--- /dev/null
+++ b/recipes/python/python-lxml_2.2.6.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Powerful and Pythonic XML processing library combining \
+libxml2/libxslt with the ElementTree API."
+HOMEPAGE = "http://codespeak.net/lxml"
+LICENSE = "BSD"
+SRCNAME = "lxml"
+PR = "r0"
+DEPENDS = "libxml2 libxslt"
+RDEPENDS_${PN} += "libxml2 libxslt python-compression"
+
+SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml"
+SRC_URI[lxml.md5sum] = "b1f700fb22d7ee9b977ee3eceb65b20c"
+SRC_URI[lxml.sha256sum] = "7fd36e4a56360cd5d7319e357b04a90e2c6b836ea220c88f9451c300ae33cc5e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DISTUTILS_BUILD_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_NATIVE}/xml2-config' \
+"
+
+DISTUTILS_INSTALL_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_NATIVE}/xml2-config' \
+"