aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-10-06 13:00:49 +0200
committerKoen Kooi <koen@openembedded.org>2010-10-06 13:24:14 +0200
commit77869f42611c2bd93fd5114484e42920c95f5225 (patch)
tree49c38fac4194c10a00117d715d675d497fc88c58 /recipes/powervr-drivers
parentf1822d1110b1fb964cf66d66047364f6ab0fc75e (diff)
downloadopenembedded-77869f42611c2bd93fd5114484e42920c95f5225.tar.gz
omap3-sgx-modules: update to latest SDK release and add ti816x support
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/powervr-drivers')
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb27
1 files changed, 17 insertions, 10 deletions
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
index 5342dc7e0f..e6baa0495e 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
@@ -1,8 +1,6 @@
DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
LICENSE = "GPLv2"
-PR_append = "d"
-
# download required binary distribution from:
# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
# see libgles-omap3.inc for detailed installation instructions
@@ -10,29 +8,38 @@ PR_append = "d"
TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
require ../ti/ti-eula-unpack.inc
-SGXPV = "3_01_00_07"
+SGXPV = "4_00_00_01"
IMGPV = "1.4.14.2616"
-BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
+BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
-SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
"
-S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}/GFX_Linux_KM"
+SRC_URI[md5sum] = "a027002dcd7164df467b1a315788d5fd"
+SRC_URI[sha256sum] = "62383d15e33adf9349afba063b0f2405a15aa6c4b0b5579b0abdf81db7580df7"
+
+S = "${WORKDIR}/Graphics_SDK_${SGXPV}/GFX_Linux_KM"
inherit module
+MACHINE_KERNEL_PR_append = "e"
+
PVRBUILD = "release"
PACKAGE_STRIP = "no"
-MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=omap3630"
+TI_PLATFORM_omap3 = "omap3630"
+TI_PLATFORM_ti816x = "ti8168"
+
+MODULESLOCATION_omap3 = "dc_omap3430_linux"
+MODULESLOCATION_ti816x = "dc_ti8168_linux"
+
+MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}"
do_install() {
mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
cp ${S}/pvrsrvkm.ko \
- ${S}/services4/3rdparty/dc_omap3430_linux/omaplfb.ko \
+ ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
}
-SRC_URI[md5sum] = "b33a82d393ed0a6c26ad0d952542d762"
-SRC_URI[sha256sum] = "6f1720c2a8c2ce84b0020e144c2d77b56106a1fff45b44f8fcfd74d0f2559d8e"