aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-native_5.10.1.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-07-07 10:04:27 -0700
committerTom Rini <tom_rini@mentor.com>2010-07-07 10:06:06 -0700
commit71a16be679041bb042c02f0f59c56141d963562c (patch)
tree8347f18665270c635292ef5f717aaf3c01d7f88a /recipes/perl/perl-native_5.10.1.bb
parent38b4324c740e4495dc352ee8514a4cce514c3f35 (diff)
downloadopenembedded-71a16be679041bb042c02f0f59c56141d963562c.tar.gz
perl-native: Add a CPAN/Config.pm file
Without this, cpan stuff can get in an infinite loop. We try and pick a good enough mirror but if needed could add CPAN_MIRROR to bitbake.conf and regex that in as well. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/perl/perl-native_5.10.1.bb')
-rw-r--r--recipes/perl/perl-native_5.10.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 8bafff0b34..0e0854b6d1 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r3"
+PR = "r4"
NATIVE_INSTALL_WORKS = "1"
# Not tested enough
@@ -12,6 +12,7 @@ DEFAULT_PREFERENCE = "-1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
+ file://CPAN-Config.pm \
file://Configure-multilib.patch \
file://perl-configpm-switch.patch \
file://native-nopacklist.patch \
@@ -92,6 +93,9 @@ do_install() {
thread.h warnings.h; do
install $i ${D}${libdir}/perl/${PV}/CORE
done
+ # Make sure CPAN is configured
+ sed -e "s,@SYSROOTBASE@,${base_prefix}," ${WORKDIR}/CPAN-Config.pm > \
+ ${D}${libdir}/perl/${PV}/CPAN/Config.pm
# Fix Errno.pm for target builds
sed -i -r "s,^\tdie\ (\"Errno\ architecture.+)$,\twarn\ \1," ${D}${libdir}/perl/${PV}/Errno.pm