aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-5.10.1/Makefile.patch
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-04 14:56:21 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 00:45:25 +0300
commit652b665d0b6a7f7a71405ee4568a487ffc516fa8 (patch)
tree9cc1fca12ceda15e5ec5e6c31ac38c6fc7d1f98d /recipes/perl/perl-5.10.1/Makefile.patch
parent5ae979b0ab285bc06fdd51c133379e91bea7de34 (diff)
downloadopenembedded-652b665d0b6a7f7a71405ee4568a487ffc516fa8.tar.gz
perl: add version 5.10.1
Brings perl up to date. Biggest packaging change - make use of Debian patchset as whole. OE used lots of Debian patches anyway and the overall setup is very similar. So instead of picking and messing with individual patches it's far more easier to just use Debian's diff.gz as a whole. Added with masked preference, since it needs more testing. Currently it was only compiled and ran on i686. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/perl/perl-5.10.1/Makefile.patch')
-rw-r--r--recipes/perl/perl-5.10.1/Makefile.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes/perl/perl-5.10.1/Makefile.patch b/recipes/perl/perl-5.10.1/Makefile.patch
new file mode 100644
index 0000000000..b929d381a7
--- /dev/null
+++ b/recipes/perl/perl-5.10.1/Makefile.patch
@@ -0,0 +1,56 @@
+Index: perl-5.10.1/Cross/Makefile
+===================================================================
+--- perl-5.10.1.orig/Cross/Makefile 2007-12-18 13:47:07.000000000 +0300
++++ perl-5.10.1/Cross/Makefile 2009-08-23 15:44:30.841492893 +0400
+@@ -2,7 +2,8 @@
+ #
+ ## $Id: Makefile,v 1.5 2003/12/12 00:48:19 red Exp red $
+
+-export TOPDIR=${shell pwd}
++override TOPDIR=${shell pwd}
++export TOPDIR
+ include $(TOPDIR)/config
+ export CFLAGS
+ export SYS=$(ARCH)-$(OS)
+@@ -12,7 +13,7 @@
+
+ export CC = $(CROSS)gcc
+ export CXX = $(CROSS)g++
+-export LD = $(CROSS)ld
++export LD = $(CC)
+ export STRIP = $(CROSS)strip
+ export AR = $(CROSS)ar
+ export RANLIB = $(CROSS)ranlib
+@@ -34,17 +35,6 @@
+ all:
+ @echo Please read the README file before doing anything else.
+
+-gen_patch:
+- diff -Bbur ../Makefile.SH Makefile.SH > Makefile.SH.patch
+- diff -Bbur ../installperl installperl > installperl.patch
+-
+-patch:
+- cd .. ; if [ ! -e ./CROSS_PATCHED ] ; then \
+- patch -p1 < Cross/Makefile.SH.patch; \
+- patch -p1 < Cross/installperl.patch ; mv installperl installperl-patched; \
+- sed -e 's/XXSTRIPXX/$(SYS)/' installperl-patched > installperl; \
+- touch CROSS_PATCHED ; fi
+-
+ perl:
+ @echo Perl cross-build directory is $(TOPDIR)
+ @echo Target arch is $(SYS)
+@@ -54,11 +44,10 @@
+ $(TOPDIR)/generate_config_sh config.sh-$(SYS) > $(TOPDIR)/../config.sh
+ cd $(TOPDIR)/.. ; ./Configure -S ; make depend ; make ; make more
+ cd $(TOPDIR)/.. ; mkdir -p fake_config_library ; cp lib/Config.pm lib/Config_heavy.pl fake_config_library
+- cd $(TOPDIR)/.. ; $(MAKE) more2 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
+- cd $(TOPDIR)/.. ; $(MAKE) more3 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
+- cd $(TOPDIR)/.. ; $(MAKE) more4 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
++ cd $(TOPDIR)/.. ; $(MAKE) more2 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
++ cd $(TOPDIR)/.. ; $(MAKE) more3 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
++ cd $(TOPDIR)/.. ; $(MAKE) more4 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
+ cd $(TOPDIR)/.. ; rm -rf install_me_here
+- cd $(TOPDIR)/.. ; make install-strip
+ cd $(TOPDIR)/.. ; sh -x Cross/warp
+
+