aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssl/openssl_1.0.0d.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-17 11:47:07 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-17 11:48:13 -0700
commitba84fd99c20d72f27e2f7823fea67a6b3905d5da (patch)
treea4382ccbbe65196982adf7e4fc4f0bd4b9d5bc66 /recipes/openssl/openssl_1.0.0d.bb
parenta2c3af2d608b1b713018d688b00e03873a538993 (diff)
downloadopenembedded-ba84fd99c20d72f27e2f7823fea67a6b3905d5da.tar.gz
openssl: Update from 1.0.0c to 1.0.0d
Security fixes only so just bumping everyone that pinned up. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/openssl/openssl_1.0.0d.bb')
-rw-r--r--recipes/openssl/openssl_1.0.0d.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/openssl/openssl_1.0.0d.bb b/recipes/openssl/openssl_1.0.0d.bb
new file mode 100644
index 0000000000..1a60e997a8
--- /dev/null
+++ b/recipes/openssl/openssl_1.0.0d.bb
@@ -0,0 +1,36 @@
+inherit pkgconfig
+
+require openssl.inc
+
+# For target side versions of openssl enable support for OCF Linux driver
+# if they are available.
+DEPENDS += "ocf-linux"
+CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
+
+SRC_URI[src.md5sum] = "40b6ea380cc8a5bf9734c2f8bf7e701e"
+SRC_URI[src.sha256sum] = "92511d1f0caaa298dba250426f8e7d5d00b271847886d1adc62422778d6320db"
+
+PR = "${INC_PR}.0"
+
+DEFAULT_PREFERENCE = "-1"
+
+export DIRS = "crypto ssl apps engines"
+export OE_LDFLAGS="${LDFLAGS}"
+
+SRC_URI += "file://configure-targets.patch \
+ file://shared-libs.patch \
+ file://debian.patch \
+ file://oe-ldflags.patch \
+ file://libdeps-first.patch \
+ file://engines-install-in-libdir-ssl.patch \
+ "
+
+PARALLEL_MAKE = ""
+
+PACKAGES += " \
+ ${PN}-engines \
+ ${PN}-engines-dbg \
+ "
+
+FILES_${PN}-engines = "${libdir}/ssl/engines/*.so"
+FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"