aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty/minneo
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-11-25 11:40:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-11-25 13:27:55 +0100
commit2bffdb50983b98f68bb6c01ed3cdcb920ba66843 (patch)
treee161b164026a5cb68d973d73363d6e78585f81b6 /recipes/openmoko-3rdparty/minneo
parent425ade7f37ee2fad43b192d7120c105da9986ac3 (diff)
downloadopenembedded-2bffdb50983b98f68bb6c01ed3cdcb920ba66843.tar.gz
minneo: bump SRCREV, add edje-native depends
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/openmoko-3rdparty/minneo')
-rw-r--r--recipes/openmoko-3rdparty/minneo/setup.py.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/minneo/setup.py.patch b/recipes/openmoko-3rdparty/minneo/setup.py.patch
new file mode 100644
index 0000000000..a7b603322f
--- /dev/null
+++ b/recipes/openmoko-3rdparty/minneo/setup.py.patch
@@ -0,0 +1,20 @@
+--- trunk.orig/setup.py 2010-11-25 13:10:09.000000000 +0100
++++ trunk/setup.py 2010-11-25 13:11:15.000000000 +0100
+@@ -50,13 +50,12 @@
+ for root, dirs, files in os.walk('data/themes/'):
+ if root == 'data/themes/' or root.find('images') >= 0 or root.find('.svn') >= 0:
+ continue
+- for i, file_name in enumerate(files):
++ theme_files = []
++ for file_name in files:
+ if file_name == 'minneo.edj':
+- files[i] = os.path.join(root, file_name)
+- else:
+- del files[i]
++ theme_files.append(os.path.join(root, file_name))
+ theme_name = os.path.basename(root)
+- l.append((os.path.join('share/minneo/themes', theme_name), files))
++ l.append((os.path.join('share/minneo/themes', theme_name), theme_files))
+ return l
+
+ def main():