aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ntop/ntop_3.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ntop/ntop_3.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ntop/ntop_3.0.bb')
-rw-r--r--recipes/ntop/ntop_3.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/ntop/ntop_3.0.bb b/recipes/ntop/ntop_3.0.bb
new file mode 100644
index 0000000000..aa725222e9
--- /dev/null
+++ b/recipes/ntop/ntop_3.0.bb
@@ -0,0 +1,38 @@
+LICENSE = "GPL"
+DESCRIPTION = "ntop is network top"
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "gdbm zlib libpcap libpng gd"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tgz \
+ file://${FILESDIR}/autotools.patch;patch=1 \
+ file://${FILESDIR}/plugins.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF += " --without-ssl \
+ --with-gd-lib=${STAGING_LIBDIR} \
+ --with-gd-include=${STAGING_INCDIR} \
+ --with-zlib-lib=${STAGING_LIBDIR} \
+ --with-zlib-include=${STAGING_INCDIR} \
+ --with-pcap-lib=${STAGING_LIBDIR} \
+ --with-pcap-include=${STAGING_INCDIR} \
+ --with-libpng-lib=${STAGING_LIBDIR} \
+ --with-libpng-include=${STAGING_INCDIR} \
+ --with-gdbm-lib=${STAGING_LIBDIR} \
+ --with-gdbm-include=${STAGING_INCDIR}"
+
+FILES_ntop_append = " ${libdir}/ntop/plugins/*.so ${libdir}/libntop-*.so \
+ ${libdir}/libntopreport-*.so"
+FILES_${PN}-dev = "${includedir} ${libdir}/libntop.so ${libdir}/libntopreport.so \
+ ${libdir}/*.a ${libdir}/libntopreport.a ${libdir}/*.la"
+FILES_${PN}-dbg += "${libdir}/ntop/plugins/.debug"
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ mv acinclude.m4.ntop acinclude.m4
+ fi
+ rm -f libtool
+ cp ${STAGING_BINDIR_NATIVE}/${TARGET_SYS}-libtool libtool
+}