aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nsd
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nsd
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nsd')
-rw-r--r--recipes/nsd/nsd_2.0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/nsd/nsd_2.0.0.bb b/recipes/nsd/nsd_2.0.0.bb
new file mode 100644
index 0000000000..0614337d5b
--- /dev/null
+++ b/recipes/nsd/nsd_2.0.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "NSD is an authoritative only, high performance, simple and opensource name server"
+SECTION = "console/network"
+PRIORITY = "optional"
+
+SRC_URI = "http://www.nlnetlabs.nl/downloads/nsd/nsd-${PV}.tar.gz"
+LICENSE = "nsd"
+inherit autotools
+
+do_install() {
+ oe_runmake configdir=${D}${sysconfdir}/nsd \
+ pidfile=${D}${localstatedir}/run/nsd.pid \
+ zonesfile=${D}${sysconfdir}/nsd/nsd.zones \
+ dbfile=${D}${sysconfdir}/nsd/nsd.db \
+ configfile=${D}${sysconfdir}/nsd/nsdc.conf \
+ zonesdir=${D}${sysconfdir}/nsd \
+ prefix=${D}${prefix} \
+ exec_prefix=${D}${exec_prefix} \
+ sbindir=${D}${sbindir} \
+ mandir=${D}${mandir} \
+ install
+}
+