aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/neuros-public/neuros-mainmenu_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/neuros-public/neuros-mainmenu_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/neuros-public/neuros-mainmenu_git.bb')
-rw-r--r--recipes/neuros-public/neuros-mainmenu_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/neuros-public/neuros-mainmenu_git.bb b/recipes/neuros-public/neuros-mainmenu_git.bb
new file mode 100644
index 0000000000..3f1c0fdf95
--- /dev/null
+++ b/recipes/neuros-public/neuros-mainmenu_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Neuros window manager"
+LICENSE = "GPL"
+
+PV = "0.0+${PR}+gitr${SRCREV}"
+PR = "r2"
+
+DEPENDS = "qt-embedded"
+
+inherit qt4e
+
+SRCREV = "4dfc8ec91c284be45582bc51de8117610269d04d"
+SRC_URI = "git://git.neurostechnology.com/git/app-mainmenu;protocol=git"
+S = "${WORKDIR}/git/"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/build/main-menu ${D}/${bindir}
+
+ install -d ${D}/${sysconfdir}/menu
+ install -m 0644 ${S}/resources/menu/* ${D}/${sysconfdir}/menu
+
+ install -d ${D}/${sysconfdir}/nwm
+ echo "${bindir}/mainmenu" > ${D}/${sysconfdir}/nwm/startup
+}
+
+