aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netperf
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-01-18 12:03:04 -0700
committerChris Larson <chris_larson@mentor.com>2011-01-18 17:28:27 -0700
commite4193a20d7aba7fb5de102f63a588365366cc306 (patch)
treec5284692c6fc01468927aa4e2e56a9bfd1a33d79 /recipes/netperf
parenta2539e0e25b0713d9b64595f3271281109cabc7e (diff)
downloadopenembedded-e4193a20d7aba7fb5de102f63a588365366cc306.tar.gz
netperf: apply patch to fall back from fork to vfork
Patch courtesy Freescale. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/netperf')
-rwxr-xr-xrecipes/netperf/files/vfork.patch28
-rw-r--r--recipes/netperf/netperf_2.4.4.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes/netperf/files/vfork.patch b/recipes/netperf/files/vfork.patch
new file mode 100755
index 0000000000..adbe8c6f3c
--- /dev/null
+++ b/recipes/netperf/files/vfork.patch
@@ -0,0 +1,28 @@
+diff --exclude CVS -uNr netperf-2.4.3/src/netserver.c netperf-2.4.3.modified/src/netserver.c
+--- netperf-2.4.3/src/netserver.c 2007-02-15 18:22:40.000000000 -0700
++++ netperf-2.4.3.modified/src/netserver.c 2007-12-05 11:42:25.000000000 -0700
+@@ -567,7 +567,11 @@
+ fflush (stdin);
+ fflush (stdout);
+ fflush (stderr);
++#if defined(HAVE_FORK)
+ switch (fork())
++#else
++ switch (vfork())
++#endif
+ {
+ case -1:
+ perror("netperf server error");
+@@ -711,8 +715,11 @@
+ }
+ #else
+ signal(SIGCLD, SIG_IGN);
+-
++#if defined(HAVE_FORK)
+ switch (fork())
++#else
++ switch (vfork())
++#endif
+ {
+ case -1:
+ /* something went wrong */
diff --git a/recipes/netperf/netperf_2.4.4.bb b/recipes/netperf/netperf_2.4.4.bb
index 8a3e159a87..783cd552b4 100644
--- a/recipes/netperf/netperf_2.4.4.bb
+++ b/recipes/netperf/netperf_2.4.4.bb
@@ -2,10 +2,11 @@ DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets
SECTION = "console/network"
HOMEPAGE = "http://www.netperf.org/"
LICENSE = "netperf"
-PR = "r1"
+PR = "r2"
SRC_URI="ftp://ftp.netperf.org/netperf/archive/netperf-${PV}.tar.bz2 \
file://cpu_set.patch \
+ file://vfork.patch \
file://init"
inherit update-rc.d autotools