aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla
diff options
context:
space:
mode:
authorPatrik Dahlström <patda293@student.liu.se>2011-04-15 18:42:40 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-04-25 23:35:58 +0200
commit03d5dcf53f6f0b8adca5a5c050133a7a57a63a29 (patch)
tree8ad724cc6ca3076c439fc4946038510c3ef86884 /recipes/mozilla
parent7abb8142f909b8266ee38b95ea1748ea6100554a (diff)
downloadopenembedded-03d5dcf53f6f0b8adca5a5c050133a7a57a63a29.tar.gz
firefox: add correct CFLAGS and LIBS of libIDL-2.0
* autoconf does not fill in any CFLAGS or LIBS for libIDL-2.0. This patch sets the appropriate flags in autoconf.mk.in for HOST_LIBIDL_CFLAGS and HOST_LIBIDL_LIBS. The error message is the following [1][2]. […] gcc -o host_xpidl.o -c -isystem/home/neil/overo-oe/tmp-unstable/sysroots/x86_64-linux/usr/include -O2 -g -DXP_UNIX -O3 -DMDCPUCFG=\"md/_linux.cfg\" -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub -I/home/neil/overo-oe/tmp-unstable/work/armv7a-angstrom-linux-gnueabi/firefox-3.6.8-r3/mozilla-1.9.2/dist/include/nspr -I/home/neil/overo-oe/tmp-unstable/work/armv7a-angstrom-linux-gnueabi/firefox-3.6.8-r3/mozilla-1.9.2/dist/include/nss -I/home/neil/overo-oe/tmp-unstable/work/armv7a-angstrom-linux-gnueabi/firefox-3.6.8-r3/mozilla-1.9.2/dist/include/nspr xpidl.c […] In file included from xpidl.c:42: xpidl.h:49: fatal error: glib.h: No such file or directoryIn file included from xpidl_util.c:42: xpidl.h:49: fatal error: glib.h: No such file or directory […] Why this did not occur earlier is not known. The patch is tested using `angstrom-2010.x` and `minimal` for `MACHINE = "beagleboard"`. It still does not build using `minimal-uclibc`. [1] http://lists.linuxtogo.org/pipermail/openembedded-devel/2011-April/031792.html [2] http://lists.linuxtogo.org/pipermail/openembedded-devel/2011-April/031959.html Signed-off-by: Patrik Dahlström <patda293@student.liu.se> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
Diffstat (limited to 'recipes/mozilla')
-rw-r--r--recipes/mozilla/firefox_3.6.8.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes/mozilla/firefox_3.6.8.bb b/recipes/mozilla/firefox_3.6.8.bb
index 04dde08989..348c8c0a4a 100644
--- a/recipes/mozilla/firefox_3.6.8.bb
+++ b/recipes/mozilla/firefox_3.6.8.bb
@@ -37,7 +37,9 @@ EXTRA_OECONF += " --enable-official-branding --disable-crashreporter"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
- cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
- sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+ sed -i "s|HOST_LIBIDL_CFLAGS = \@HOST_LIBIDL_CFLAGS\@|HOST_LIBIDL_CFLAGS = $(pkg-config --cflags libIDL-2.0)|" config/autoconf.mk.in
+ sed -i "s|HOST_LIBIDL_LIBS = @HOST_LIBIDL_LIBS@|HOST_LIBIDL_LIBS = $(pkg-config --libs libIDL-2.0)|" config/autoconf.mk.in
}