aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mono/mono-native_2.6.3.bb
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2010-05-11 11:06:47 -0400
committerShane Volpe <shanevolpe@gmail.com>2010-05-13 09:15:53 -0400
commit21600c8a338c5052ff6fbfa3d4cbb2ec37453242 (patch)
tree982b0509840d287ffe191675e9844650c20dbb31 /recipes/mono/mono-native_2.6.3.bb
parent93a439a42b538be1f96c9250122504bfbdbd8d7b (diff)
downloadopenembedded-21600c8a338c5052ff6fbfa3d4cbb2ec37453242.tar.gz
mono: Add version 2.6.3
* Removed old versions of mono as they were broken. * Fixed mono packages so mono now builds with new native staging. * Changed mono floating point to ARM_FPU_NONE so it works with all architectures. * Added libtoolize --force --copy to mono.inc to allow any libtool version to work.
Diffstat (limited to 'recipes/mono/mono-native_2.6.3.bb')
-rw-r--r--recipes/mono/mono-native_2.6.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/mono/mono-native_2.6.3.bb b/recipes/mono/mono-native_2.6.3.bb
new file mode 100644
index 0000000000..03820d3cd3
--- /dev/null
+++ b/recipes/mono/mono-native_2.6.3.bb
@@ -0,0 +1,22 @@
+require mono.inc
+DEPENDS = "glib-2.0-native perl-native"
+
+PR = "${INC_PR}.0"
+
+SRC_URI += ""
+
+inherit native
+
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure
+
+SRC_URI[md5sum] = "b1dc21bac2c7c75814a9f32246eadadd"
+SRC_URI[sha256sum] = "0ecb82d2007f472f8eebc85c349813515bf642e6ea021890ece40555ad50d947"
+