aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtool/libtool_2.4.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-11 18:23:01 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-11 18:28:08 -0700
commita92ca415ac94fdb208fd9d3340382d0d4809c4a0 (patch)
tree77776401d446d7970ddf28e104b2549486a682fd /recipes/libtool/libtool_2.4.bb
parent0cb515879ab62d805b3ec712dfd9748e994263ac (diff)
downloadopenembedded-a92ca415ac94fdb208fd9d3340382d0d4809c4a0.tar.gz
libtool: Abstact more common things to libtool.inc
* inherit autotools is now in libtool.inc and so is EXTRA_AUTORECONF = "--exclude=libtoolize" * Include libtool.inc separately into -cross -native -sdk and -nativesdk recipes for 2.4 this avoids the problem where libltdl etc are also provided by -sdk and -nativesdk recipes which is incorrect * Delete ${D}${infodir}/dir this should be regenerated at install time Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libtool/libtool_2.4.bb')
-rw-r--r--recipes/libtool/libtool_2.4.bb23
1 files changed, 3 insertions, 20 deletions
diff --git a/recipes/libtool/libtool_2.4.bb b/recipes/libtool/libtool_2.4.bb
index a928be2dbc..c7c56fda47 100644
--- a/recipes/libtool/libtool_2.4.bb
+++ b/recipes/libtool/libtool_2.4.bb
@@ -5,11 +5,6 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS = "libtool-native"
PR = "${INC_PR}.0"
-SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
- file://trailingslash.patch \
- file://prefix-manpage-fix.patch \
- file://resolve-sysroot.patch \
- "
SRC_URI[md5sum] = "b32b04148ecdd7344abc6fe8bd1bb021"
SRC_URI[sha256sum] = "13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e"
PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
@@ -18,26 +13,14 @@ FILES_libltdl = "${libdir}/libltdl.so.*"
FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
FILES_libltdl-dbg = "${libdir}/.debug/"
-inherit autotools
-
-EXTRA_AUTORECONF = "--exclude=libtoolize"
-EXTRA_OECONF = " --with-sysroot"
-do_compile_prepend () {
- # Sometimes this file doesn't get rebuilt, force the issue
- rm -f ${S}/libltdl/config/ltmain.sh
- make libltdl/config/ltmain.sh
-}
-
#
# We want the results of libtool-cross preserved - don't stage anything ourselves.
#
SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess"
libtool_sysroot_preprocess () {
- if [ "${PN}" == "libtool" ]; then
- rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${bindir}/*
- rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/aclocal/*
- rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/libtool/config/*
- fi
+ rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${bindir}/*
+ rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/aclocal/*
+ rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/libtool/config/*
}