aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libc-client
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2011-03-13 15:34:59 +0100
committerEric Bénard <eric@eukrea.com>2011-03-13 22:09:46 +0100
commit4992524e798f6371ce603c6a97a4f9f694f0e2fe (patch)
treeaa535694e3d3b3329789470dce1d961d1b42a498 /recipes/libc-client
parentaeb1d38cb5bb88054cc4117eec87558fd28b536e (diff)
downloadopenembedded-4992524e798f6371ce603c6a97a4f9f694f0e2fe.tar.gz
libc-client: add 2007e
Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libc-client')
-rw-r--r--recipes/libc-client/libc-client_2007e.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/libc-client/libc-client_2007e.bb b/recipes/libc-client/libc-client_2007e.bb
new file mode 100644
index 0000000000..416d6523e4
--- /dev/null
+++ b/recipes/libc-client/libc-client_2007e.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "UW c-client library for mail protocols"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "University of Washingtons Free-Fork License"
+DEPENDS = "libpam openssl libpam"
+
+SRC_URI = "ftp://ftp.cac.washington.edu/imap/imap-${PV}.tar.gz \
+ file://quote_cctype.patch"
+
+S = "${WORKDIR}/imap-${PV}"
+
+EXTRA_OEMAKE = "CC='${CC}'"
+
+HEADERS = "src/c-client/*.h src/osdep/unix/*.h c-client/auths.c c-client/linkage.c c-client/linkage.h c-client/osdep.h"
+
+do_compile() {
+ echo "SSLINCLUDE=${STAGING_INCDIR} SSLLIB=${STAGING_LIBDIR}" > ${S}/SPECIALS
+ oe_runmake lnp
+}
+
+do_install() {
+ install -d ${D}${includedir}/c-client
+ install ${HEADERS} ${D}${includedir}/c-client
+ install -d ${D}${libdir}
+ install c-client/c-client.a ${D}${libdir}/libc-client.a
+}
+
+SRC_URI[md5sum] = "7903800dc2604000016de070e0c55840"
+SRC_URI[sha256sum] = "4b1137b87249782496ec3eeacaf83bbf09312a7d2ae3aead262179041b55565f"