aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/initscripts
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2011-04-16 01:03:54 +0200
committerAndrea Adami <andrea.adami@gmail.com>2011-04-16 01:16:40 +0200
commitca45b6dbad81d1ffb983c348a229aa7fa676ad2b (patch)
treeb238541e083c4013aa4469157e8436c9a225f32f /recipes/initscripts
parentd8412cb93530294b5a232fa5ef35d9c82de64fc2 (diff)
downloadopenembedded-ca45b6dbad81d1ffb983c348a229aa7fa676ad2b.tar.gz
initscripts: remove obsolete Zaurus overrides
* check was not done against /dev/.udev thus messing devices * Angstrom distro already skips S05devices * bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes/initscripts')
-rwxr-xr-xrecipes/initscripts/initscripts-1.0/akita/devices68
-rwxr-xr-xrecipes/initscripts/initscripts-1.0/c7x0/devices68
-rwxr-xr-xrecipes/initscripts/initscripts-1.0/collie/devices67
-rwxr-xr-xrecipes/initscripts/initscripts-1.0/poodle/devices67
-rwxr-xr-xrecipes/initscripts/initscripts-1.0/spitz/devices68
-rwxr-xr-xrecipes/initscripts/initscripts-1.0/tosa/devices72
-rw-r--r--recipes/initscripts/initscripts_1.0.bb2
7 files changed, 1 insertions, 411 deletions
diff --git a/recipes/initscripts/initscripts-1.0/akita/devices b/recipes/initscripts/initscripts-1.0/akita/devices
deleted file mode 100755
index 083090ecb9..0000000000
--- a/recipes/initscripts/initscripts-1.0/akita/devices
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script. Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
- exit 0
-fi
-
-if test -e /dev/.devfsd
-then
- if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
- ln -s /dev/touchscreen/0 /dev/ts
- ln -s /dev/touchscreen/0raw /dev/tsraw
- ln -s /dev/vc/0 /dev/tty0
- ln -s /dev/vc/1 /dev/tty1
- ln -s /dev/vc/2 /dev/tty2
- ln -s /dev/vc/3 /dev/tty3
- ln -s /dev/vc/4 /dev/tty4
- ln -s /dev/vc/5 /dev/tty5
- ln -s /dev/fb/0 /dev/fb0
-# ln -s /dev/tts/0 /dev/ttySA0
-# ln -s /dev/tts/1 /dev/ttySA1
-# ln -s /dev/tts/2 /dev/ttySA2
-
- ln -s /dev/sound/dsp /dev/dsp
- ln -s /dev/sound/mixer /dev/mixer
-
- ln -s /dev/v4l/video0 /dev/video0
- ln -s /dev/v4l/video0 /dev/video
- ln -s /dev/misc/rtc /dev/rtc
-
- ## need this so that ppp will autoload the ppp modules
- mknod /dev/ppp c 108 0
- if test "$VERBOSE" != "no"; then echo "done"; fi
-else
- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
- if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
- cd /
- mkdir -p dev/msys
- mkdir -p dev/pts
- mkdir -p dev/input
- mkdir -p dev/vc
- for i in 0 1 2 3 4 5 6 7 8 9; do
- ln -s /dev/tty$i /dev/vc/$i
- done
- ln -sf /dev/sharp_ts /dev/ts
- ln -sf /dev/sharp_fl /dev/fl
- ln -sf /proc/self/fd /dev/fd
- ln -sf /proc/kcore /dev/core
- /sbin/makedevs -r / -D /etc/device_table
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
-fi
-
-exit 0
diff --git a/recipes/initscripts/initscripts-1.0/c7x0/devices b/recipes/initscripts/initscripts-1.0/c7x0/devices
deleted file mode 100755
index 083090ecb9..0000000000
--- a/recipes/initscripts/initscripts-1.0/c7x0/devices
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script. Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
- exit 0
-fi
-
-if test -e /dev/.devfsd
-then
- if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
- ln -s /dev/touchscreen/0 /dev/ts
- ln -s /dev/touchscreen/0raw /dev/tsraw
- ln -s /dev/vc/0 /dev/tty0
- ln -s /dev/vc/1 /dev/tty1
- ln -s /dev/vc/2 /dev/tty2
- ln -s /dev/vc/3 /dev/tty3
- ln -s /dev/vc/4 /dev/tty4
- ln -s /dev/vc/5 /dev/tty5
- ln -s /dev/fb/0 /dev/fb0
-# ln -s /dev/tts/0 /dev/ttySA0
-# ln -s /dev/tts/1 /dev/ttySA1
-# ln -s /dev/tts/2 /dev/ttySA2
-
- ln -s /dev/sound/dsp /dev/dsp
- ln -s /dev/sound/mixer /dev/mixer
-
- ln -s /dev/v4l/video0 /dev/video0
- ln -s /dev/v4l/video0 /dev/video
- ln -s /dev/misc/rtc /dev/rtc
-
- ## need this so that ppp will autoload the ppp modules
- mknod /dev/ppp c 108 0
- if test "$VERBOSE" != "no"; then echo "done"; fi
-else
- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
- if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
- cd /
- mkdir -p dev/msys
- mkdir -p dev/pts
- mkdir -p dev/input
- mkdir -p dev/vc
- for i in 0 1 2 3 4 5 6 7 8 9; do
- ln -s /dev/tty$i /dev/vc/$i
- done
- ln -sf /dev/sharp_ts /dev/ts
- ln -sf /dev/sharp_fl /dev/fl
- ln -sf /proc/self/fd /dev/fd
- ln -sf /proc/kcore /dev/core
- /sbin/makedevs -r / -D /etc/device_table
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
-fi
-
-exit 0
diff --git a/recipes/initscripts/initscripts-1.0/collie/devices b/recipes/initscripts/initscripts-1.0/collie/devices
deleted file mode 100755
index 9d1624428a..0000000000
--- a/recipes/initscripts/initscripts-1.0/collie/devices
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script. Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
- exit 0
-fi
-
-if test -e /dev/.devfsd
-then
- if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
- ln -s /dev/touchscreen/0 /dev/ts
- ln -s /dev/touchscreen/0raw /dev/tsraw
- ln -s /dev/vc/0 /dev/tty0
- ln -s /dev/vc/1 /dev/tty1
- ln -s /dev/vc/2 /dev/tty2
- ln -s /dev/vc/3 /dev/tty3
- ln -s /dev/vc/4 /dev/tty4
- ln -s /dev/vc/5 /dev/tty5
- ln -s /dev/fb/0 /dev/fb0
-# ln -s /dev/tts/0 /dev/ttySA0
-# ln -s /dev/tts/1 /dev/ttySA1
-# ln -s /dev/tts/2 /dev/ttySA2
-
- ln -s /dev/sound/dsp /dev/dsp
- ln -s /dev/sound/mixer /dev/mixer
-
- ln -s /dev/v4l/video0 /dev/video0
- ln -s /dev/v4l/video0 /dev/video
- ln -s /dev/misc/rtc /dev/rtc
-
- ## need this so that ppp will autoload the ppp modules
- mknod /dev/ppp c 108 0
- if test "$VERBOSE" != "no"; then echo "done"; fi
-else
- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
- if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
- cd /
- mkdir -p dev/msys
- mkdir -p dev/pts
- mkdir -p dev/vc
- for i in 0 1 2 3 4 5 6 7 8 9; do
- ln -s /dev/tty$i /dev/vc/$i
- done
- ln -sf /dev/sharp_ts /dev/ts
- ln -sf /dev/sharp_fl /dev/fl
- ln -sf /proc/self/fd /dev/fd
- ln -sf /proc/kcore /dev/core
- /sbin/makedevs -r / -D /etc/device_table
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
-fi
-
-exit 0
diff --git a/recipes/initscripts/initscripts-1.0/poodle/devices b/recipes/initscripts/initscripts-1.0/poodle/devices
deleted file mode 100755
index 9d1624428a..0000000000
--- a/recipes/initscripts/initscripts-1.0/poodle/devices
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script. Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
- exit 0
-fi
-
-if test -e /dev/.devfsd
-then
- if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
- ln -s /dev/touchscreen/0 /dev/ts
- ln -s /dev/touchscreen/0raw /dev/tsraw
- ln -s /dev/vc/0 /dev/tty0
- ln -s /dev/vc/1 /dev/tty1
- ln -s /dev/vc/2 /dev/tty2
- ln -s /dev/vc/3 /dev/tty3
- ln -s /dev/vc/4 /dev/tty4
- ln -s /dev/vc/5 /dev/tty5
- ln -s /dev/fb/0 /dev/fb0
-# ln -s /dev/tts/0 /dev/ttySA0
-# ln -s /dev/tts/1 /dev/ttySA1
-# ln -s /dev/tts/2 /dev/ttySA2
-
- ln -s /dev/sound/dsp /dev/dsp
- ln -s /dev/sound/mixer /dev/mixer
-
- ln -s /dev/v4l/video0 /dev/video0
- ln -s /dev/v4l/video0 /dev/video
- ln -s /dev/misc/rtc /dev/rtc
-
- ## need this so that ppp will autoload the ppp modules
- mknod /dev/ppp c 108 0
- if test "$VERBOSE" != "no"; then echo "done"; fi
-else
- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
- if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
- cd /
- mkdir -p dev/msys
- mkdir -p dev/pts
- mkdir -p dev/vc
- for i in 0 1 2 3 4 5 6 7 8 9; do
- ln -s /dev/tty$i /dev/vc/$i
- done
- ln -sf /dev/sharp_ts /dev/ts
- ln -sf /dev/sharp_fl /dev/fl
- ln -sf /proc/self/fd /dev/fd
- ln -sf /proc/kcore /dev/core
- /sbin/makedevs -r / -D /etc/device_table
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
-fi
-
-exit 0
diff --git a/recipes/initscripts/initscripts-1.0/spitz/devices b/recipes/initscripts/initscripts-1.0/spitz/devices
deleted file mode 100755
index 083090ecb9..0000000000
--- a/recipes/initscripts/initscripts-1.0/spitz/devices
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script. Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
- exit 0
-fi
-
-if test -e /dev/.devfsd
-then
- if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
- ln -s /dev/touchscreen/0 /dev/ts
- ln -s /dev/touchscreen/0raw /dev/tsraw
- ln -s /dev/vc/0 /dev/tty0
- ln -s /dev/vc/1 /dev/tty1
- ln -s /dev/vc/2 /dev/tty2
- ln -s /dev/vc/3 /dev/tty3
- ln -s /dev/vc/4 /dev/tty4
- ln -s /dev/vc/5 /dev/tty5
- ln -s /dev/fb/0 /dev/fb0
-# ln -s /dev/tts/0 /dev/ttySA0
-# ln -s /dev/tts/1 /dev/ttySA1
-# ln -s /dev/tts/2 /dev/ttySA2
-
- ln -s /dev/sound/dsp /dev/dsp
- ln -s /dev/sound/mixer /dev/mixer
-
- ln -s /dev/v4l/video0 /dev/video0
- ln -s /dev/v4l/video0 /dev/video
- ln -s /dev/misc/rtc /dev/rtc
-
- ## need this so that ppp will autoload the ppp modules
- mknod /dev/ppp c 108 0
- if test "$VERBOSE" != "no"; then echo "done"; fi
-else
- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
- if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
- cd /
- mkdir -p dev/msys
- mkdir -p dev/pts
- mkdir -p dev/input
- mkdir -p dev/vc
- for i in 0 1 2 3 4 5 6 7 8 9; do
- ln -s /dev/tty$i /dev/vc/$i
- done
- ln -sf /dev/sharp_ts /dev/ts
- ln -sf /dev/sharp_fl /dev/fl
- ln -sf /proc/self/fd /dev/fd
- ln -sf /proc/kcore /dev/core
- /sbin/makedevs -r / -D /etc/device_table
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
-fi
-
-exit 0
diff --git a/recipes/initscripts/initscripts-1.0/tosa/devices b/recipes/initscripts/initscripts-1.0/tosa/devices
deleted file mode 100755
index 61cfd9d7b9..0000000000
--- a/recipes/initscripts/initscripts-1.0/tosa/devices
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-#
-# Devfs handling script. Since we arent running devfsd due to various reasons
-# which I will not lay out here, we need to create some links for compatibility.
-
-. /etc/default/rcS
-
-# exit without doing anything if udev is active
-if test -e /dev/.udevdb; then
- exit 0
-fi
-
-if test -e /dev/.devfsd
-then
- if test "$VERBOSE" != "no"; then echo -n "Setting up device links for devfs: "; fi
- ln -s /dev/touchscreen/0 /dev/ts
- ln -s /dev/touchscreen/0raw /dev/tsraw
- ln -s /dev/vc/0 /dev/tty0
- ln -s /dev/vc/1 /dev/tty1
- ln -s /dev/vc/2 /dev/tty2
- ln -s /dev/vc/3 /dev/tty3
- ln -s /dev/vc/4 /dev/tty4
- ln -s /dev/vc/5 /dev/tty5
- ln -s /dev/fb/0 /dev/fb0
-# ln -s /dev/tts/0 /dev/ttySA0
-# ln -s /dev/tts/1 /dev/ttySA1
-# ln -s /dev/tts/2 /dev/ttySA2
-
- ln -s /dev/sound/dsp /dev/dsp
- ln -s /dev/sound/mixer /dev/mixer
-
- ln -s /dev/v4l/video0 /dev/video0
- ln -s /dev/v4l/video0 /dev/video
- ln -s /dev/misc/rtc /dev/rtc
-
- ## need this so that ppp will autoload the ppp modules
- mknod /dev/ppp c 108 0
- if test "$VERBOSE" != "no"; then echo "done"; fi
-else
- if test "$VERBOSE" != "no"; then echo -n "Mounting /dev ramdisk: "; fi
- mount -t ramfs ramfs /dev || mount -t tmpfs ramfs /dev
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
- if test "$VERBOSE" != "no"; then echo -n "Populating /dev: "; fi
- cd /
- mkdir -p dev/msys
- mkdir -p dev/pts
- mkdir -p dev/input
- mkdir -p dev/vc
- for i in 0 1 2 3 4 5 6 7 8 9; do
- ln -s /dev/tty$i /dev/vc/$i
- done
- ln -sf /dev/sharp_ts /dev/ts
- ln -sf /dev/sharp_fl /dev/fl
- ln -sf /proc/self/fd /dev/fd
- ln -sf /proc/kcore /dev/core
- /sbin/makedevs -r / -D /etc/device_table
- if test $? -ne 0; then
- if test "$VERBOSE" != "no"; then echo "failed"; fi
- else
- if test "$VERBOSE" != "no"; then echo "done"; fi
- fi
-fi
-
-#Always turn on usb
-if [ ! -d /dev/usb ]; then mkdir /dev/usb; fi
-mknod /dev/usb/host_ohci c 10 222
-
-exit 0
diff --git a/recipes/initscripts/initscripts_1.0.bb b/recipes/initscripts/initscripts_1.0.bb
index fc0086e175..f5bc42fb1f 100644
--- a/recipes/initscripts/initscripts_1.0.bb
+++ b/recipes/initscripts/initscripts_1.0.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
DEPENDS = "makedevs"
RDEPENDS_${PN} = "makedevs"
LICENSE = "GPL"
-PR = "r126"
+PR = "r127"
SRC_URI = "file://functions \
file://halt \