aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk-webcore
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-09-24 13:56:55 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-24 13:56:55 +0200
commit065ed847e424e2d21659f23010e1e1b0e9d02fe2 (patch)
tree13fc97d06dbaa625325a0b131d8be2a9936b4e8c /recipes/gtk-webcore
parent5d462f7230c2ced6baecf516103b616ab6933b74 (diff)
downloadopenembedded-065ed847e424e2d21659f23010e1e1b0e9d02fe2.tar.gz
midori: add 0.2.8
* waf hacks aren't necessary anymore \o/
Diffstat (limited to 'recipes/gtk-webcore')
-rwxr-xr-xrecipes/gtk-webcore/midori/waf (renamed from recipes/gtk-webcore/files/waf)bin75695 -> 75695 bytes
-rw-r--r--recipes/gtk-webcore/midori_0.2.8.bb36
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/gtk-webcore/files/waf b/recipes/gtk-webcore/midori/waf
index a22ad09a74..a22ad09a74 100755
--- a/recipes/gtk-webcore/files/waf
+++ b/recipes/gtk-webcore/midori/waf
Binary files differ
diff --git a/recipes/gtk-webcore/midori_0.2.8.bb b/recipes/gtk-webcore/midori_0.2.8.bb
new file mode 100644
index 0000000000..9355730b1b
--- /dev/null
+++ b/recipes/gtk-webcore/midori_0.2.8.bb
@@ -0,0 +1,36 @@
+require midori.inc
+
+DEPENDS += "vala-native python-native python-docutils-native"
+
+SRC_URI = "http://archive.xfce.org/src/apps/midori/0.2/midori-${PV}.tar.bz2;name=midori \
+"
+
+SRC_URI[midori.md5sum] = "56bad3b922a4a4dcfe74186ca136d818"
+SRC_URI[midori.sha256sum] = "1f91829a036f28c55c15538545ede2c195685a01075dc01c88741996cf098be1"
+
+SRC_URI_append_shr = " file://config \
+"
+
+do_configure() {
+ sed -i -e 's:, shell=False::g' wscript
+ ./configure \
+ --prefix=${prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF}
+}
+
+do_install_append_shr() {
+ install -d ${D}${sysconfdir}/xdg/midori
+ install -m 0644 ${WORKDIR}/config ${D}${sysconfdir}/xdg/midori
+}
+