aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-10-13 20:56:59 -0700
committerKoen Kooi <koen@openembedded.org>2009-10-14 14:09:49 +0200
commitd6c0a8bf7620cb0c8df56baae576df9c14ae66a6 (patch)
treee3aef2ff51bc851715dbf3b2cb00019bbfc642da /recipes/gnome
parent42e5ebf75aeecff10e6cf34932b260f27bfe8c5e (diff)
downloadopenembedded-d6c0a8bf7620cb0c8df56baae576df9c14ae66a6.tar.gz
libgweather: add 2.28.0
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/libgweather_2.28.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/gnome/libgweather_2.28.0.bb b/recipes/gnome/libgweather_2.28.0.bb
new file mode 100644
index 0000000000..5b2dc305e6
--- /dev/null
+++ b/recipes/gnome/libgweather_2.28.0.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPL"
+SECTION = "x11/gnome/libs"
+DEPENDS = "libgnome libsoup-2.4 gtk+ gnome-keyring"
+
+inherit gnome
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_prepend() {
+ sed -i -e 's:help::' ${S}/Makefile.am
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gnome* \
+ ${datadir}/icons"
+
+PACKAGES =+ "${PN}-locationdata"
+FILES_${PN}-locationdata = "${datadir}/libgweather/Locations*"
+