aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-cross-sdk_svn.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-03-11 09:25:58 -0700
committerTom Rini <tom_rini@mentor.com>2010-03-11 09:25:58 -0700
commit74b6e5ac1ba79357428c624d0972f182e7a446be (patch)
tree5ace4a012af60e82c4986f48eb112b0c48c81e1b /recipes/gcc/gcc-cross-sdk_svn.bb
parente3dabea86d41069f12f637e81d854a5937d910d6 (diff)
downloadopenembedded-pb/toolchain-desuck.tar.gz
Revert "Pull mpfr/gmp builds into gcc builds". This doesn't fix thepb/toolchain-desuck
problem with gcc-cross-sdk & company linking against stuff we don't ship. After talking with Khem and pb, lets try using the crosssdk / nativesdk stuff if we can to get static libs for gcc to use. This reverts commit f38f68c348506605c32b7eaf69c194a802b3c80d. Conflicts: recipes/gcc/gcc-4.4.1.inc recipes/gcc/gcc-4.4.2.inc recipes/gcc/gcc-4.4.3.inc
Diffstat (limited to 'recipes/gcc/gcc-cross-sdk_svn.bb')
-rw-r--r--recipes/gcc/gcc-cross-sdk_svn.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes/gcc/gcc-cross-sdk_svn.bb b/recipes/gcc/gcc-cross-sdk_svn.bb
index 0ae3dcb6fd..48d8a0d1ed 100644
--- a/recipes/gcc/gcc-cross-sdk_svn.bb
+++ b/recipes/gcc/gcc-cross-sdk_svn.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r1"
inherit sdk
@@ -7,7 +7,8 @@ require gcc-cross-sdk.inc
require gcc-configure-sdk.inc
require gcc-package-sdk.inc
-DEPENDS += "libmpc-native"
+DEPENDS += "libmpc-native gmp-native mpfr-native"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
- --disable-libgomp --disable-libmudflap"
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"