aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eglibc/eglibc_2.10.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-12-13 13:48:16 -0800
committerKhem Raj <raj.khem@gmail.com>2010-12-14 12:09:08 -0800
commit4e6b1bfe289ad346cbd84926a43ad0f93760930d (patch)
tree6aca4f22c736339a0238a25ccfe25608d5ecf475 /recipes/eglibc/eglibc_2.10.bb
parentc63e599a33bbb8fb389b603309dbdcc0915b13b0 (diff)
downloadopenembedded-4e6b1bfe289ad346cbd84926a43ad0f93760930d.tar.gz
eglibc/glibc: Use/add cross-localedef to generate locales
* Add recipe for cross-localedef-native * Consolidate eglibc/glibc to share common contructs in bbclass * Move common code in eglibc to eglibc.inc * By default use cross-locaedef to generate locales now instead of qemu Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/eglibc/eglibc_2.10.bb')
-rw-r--r--recipes/eglibc/eglibc_2.10.bb15
1 files changed, 1 insertions, 14 deletions
diff --git a/recipes/eglibc/eglibc_2.10.bb b/recipes/eglibc/eglibc_2.10.bb
index 1eab7ebeb3..d9867044cf 100644
--- a/recipes/eglibc/eglibc_2.10.bb
+++ b/recipes/eglibc/eglibc_2.10.bb
@@ -51,19 +51,6 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--without-selinux \
${GLIBC_EXTRA_OECONF}"
-EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}"
-
-do_unpack_append() {
- bb.build.exec_func('do_move_ports', d)
-}
-
-do_move_ports() {
- if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
- rm -rf ${S}/ports
- mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
- fi
-}
-
do_configure () {
# override this function to avoid the autoconf/automake/aclocal/autoheader
# calls for now
@@ -95,4 +82,4 @@ do_compile () {
)
}
-require eglibc-package.bbclass
+require eglibc-package.inc