aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-05-10 15:39:10 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-10 10:33:17 +0200
commit819fa4c451ea5a811b8dd78bbcbb38dc38c68aa4 (patch)
treed979c53a82547be33b077b60da44b10fdcea8d46 /recipes/efl1
parent465521a22a064ccfe50d769a3c39f93f59095a80 (diff)
downloadopenembedded-819fa4c451ea5a811b8dd78bbcbb38dc38c68aa4.tar.gz
recipes: fix LICENSE fields
* & in LICENSE breaks distribute_sources ERROR: Function 'SRC_DISTRIBUTECOMMAND' failed (see /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/pixman-0.22.0-r5.0/temp/log.do_distribute_sources.17340 for further information) ERROR: Logfile of failure stored in: /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/pixman-0.22.0-r5.0/temp/log.do_distribute_sources.17340 Log data follows: | WARNING: LICENSE: 'PublicDomain & MIT & MIT-style' | WARNING: licenses: ['PublicDomain', '&', 'MIT', '&', 'MIT-style'] | WARNING: license: PublicDomain | WARNING: license: & | ERROR: Function 'SRC_DISTRIBUTECOMMAND' failed (see /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/pixman-0.22.0-r5.0/temp/log.do_distribute_sources.17340 for further information) | + cd /OE/tmpdir-shr/deploy/sources/PublicDomain/pixman | + SRC_DISTRIBUTECOMMAND | + test -e /OE/pixman-0.22.0.tar.gz.md5 | + ln -sf /OE/pixman-0.22.0.tar.gz . | + /pixman | + cd /OE/tmpdir-shr/deploy/sources/ | /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/pixman-0.22.0-r5.0/temp/run.SRC_DISTRIBUTECOMMAND.17340: line 95: /pixman: No such file or directory NOTE: package pixman-0.22.0-r5.0: task do_distribute_sources: Failed * "Public Domain" causes sources distributed from "Public" and "Domain" folders which is not expected, so use PD as in other recipes * embryo and epdf had LICENSE defined before inherit efl which overwrites it (that's why distribute_sources wasn't failing on their & Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/embryo.inc7
-rw-r--r--recipes/efl1/epdf_svn.bb10
2 files changed, 10 insertions, 7 deletions
diff --git a/recipes/efl1/embryo.inc b/recipes/efl1/embryo.inc
index ab0290511e..8bb8b6fbf0 100644
--- a/recipes/efl1/embryo.inc
+++ b/recipes/efl1/embryo.inc
@@ -1,11 +1,12 @@
DESCRIPTION = "The Enlightenment C-like scripting language for Edje"
-LICENSE = "MIT BSD & CompuPhase"
-LIC_FILES_CHKSUM = "file://COPYING;md5=6aa45e26c1ed178da910fd76b306a875"
inherit efl
+LICENSE = "MIT BSD CompuPhase"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6aa45e26c1ed178da910fd76b306a875"
+
BBCLASSEXTEND = "native"
-INC_PR = "r0"
+INC_PR = "r1"
# Some upgrade path tweaking
AUTO_LIBNAME_PKGS = ""
diff --git a/recipes/efl1/epdf_svn.bb b/recipes/efl1/epdf_svn.bb
index 1f3762991e..490b3cea37 100644
--- a/recipes/efl1/epdf_svn.bb
+++ b/recipes/efl1/epdf_svn.bb
@@ -1,8 +1,4 @@
DESCRIPTION = "Epdf is the glue between EFL and libpoppler"
-LICENSE = "GPLv2 & LGPLv3"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
- file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \
-"
DEPENDS = "poppler evas ecore"
PV = "0.1.0+svnr${SRCPV}"
@@ -10,6 +6,12 @@ PR = "r4"
SRCREV = "${EFL_SRCREV}"
inherit efl
+
+LICENSE = "GPLv2 LGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \
+"
+
SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};proto=http;scmdata=keep"
S = "${WORKDIR}/${SRCNAME}"