aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin.shar@gmail.com>2010-12-06 00:17:38 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-06 10:45:21 +0100
commit7ae1305321980c930b648c4cdc61cdfd96ad6570 (patch)
treee753b64f8a024adbe6e7104c111d9fecc8657644 /recipes/efl1
parentd28d552600d1fb96cc33323fbb77d45228dd7884 (diff)
downloadopenembedded-7ae1305321980c930b648c4cdc61cdfd96ad6570.tar.gz
elementary-theme-efenniht: add recipe for efenniht elementary theme.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/elementary-theme-efenniht_svn.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/efl1/elementary-theme-efenniht_svn.bb b/recipes/efl1/elementary-theme-efenniht_svn.bb
new file mode 100644
index 0000000000..c6616e3f31
--- /dev/null
+++ b/recipes/efl1/elementary-theme-efenniht_svn.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "efenniht elementary theme - Efenniht was devised to be clean and neutral. Its name (which means equinox) comes from the chromatic duality that was decided at the very beginning, with a dark theme (black and orange) and a bright one (white and blue) to be developed so that more people feel comfortable using it. Efenniht uses few animations, discrete contrasts between shades of gray and fine lines (colored) that outline the selected elements."
+SECTION = "e/utils"
+HOMEPAGE = "http://trac.enlightenment.org/e/wiki/Themes#Efenniht"
+DEPENDS = "edje-native"
+RSUGGESTS_${PN} = "e-wm-theme-illume-efenniht"
+PACKAGE_ARCH = "all"
+LICENSE = "MIT/BSD"
+
+SRCREV_pn-elementary-theme-efenniht_THM_REV ?= "${EFL_SRCREV}"
+SRCREV_pn-elementary-theme-efenniht_ELM_REV ?= "${EFL_SRCREV}"
+
+SRCREV_FORMAT = "THM_REV"
+PV = "0.0+svnr${SRCPV}"
+PACKAGE_ARCH = "all"
+
+inherit e-base
+
+SRCNAME = "efenniht"
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/THEMES;module=${SRCNAME};proto=http;name=THM_REV"
+SRC_URI += "svn://svn.enlightenment.org/svn/e/trunk/TMP/st/elementary/data;module=themes;proto=http;name=ELM_REV"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images -id ${WORKDIR}/themes/ ${S}/elm-efenniht.edc -o ${S}/elm-efenniht.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/elementary/themes/
+ install -m 0644 ${S}/elm-efenniht.edj ${D}${datadir}/elementary/themes/
+}
+
+FILES_${PN} = "${datadir}/elementary/themes/"