aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 15:49:45 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 18:56:49 +0100
commit773dea684202a9cc6d95382f0dba53bc843f5887 (patch)
tree4a17bc4b095fd31ab94a99bf3e0bf5ed3ae51344 /recipes/efl1
parent8e7b68aa3b84190c731c7d5e7a9396103ed10603 (diff)
downloadopenembedded-773dea684202a9cc6d95382f0dba53bc843f5887.tar.gz
edbus: introduce 1.0.0
* edbus_svn is now D_P -1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/edbus.inc33
-rw-r--r--recipes/efl1/edbus_1.0.0.bb11
-rw-r--r--recipes/efl1/edbus_svn.bb40
3 files changed, 52 insertions, 32 deletions
diff --git a/recipes/efl1/edbus.inc b/recipes/efl1/edbus.inc
new file mode 100644
index 0000000000..641f04acdb
--- /dev/null
+++ b/recipes/efl1/edbus.inc
@@ -0,0 +1,33 @@
+DESCRIPTION = "DBus and HAL convenience wrappers for EFL"
+DEPENDS = "dbus ecore"
+LICENSE = "MIT BSD"
+
+inherit efl
+
+BBCLASSEXTEND = "native"
+INC_PR = "r0"
+
+SRCNAME = "e_dbus"
+
+EXTRA_OECONF = "--enable-build-test-gui"
+
+PACKAGES =+ "${PN}-enotify ${PN}-edbus ${PN}-enm ${PN}-ehal ${PN}-econnman ${PN}-eofono ${PN}-eukit ${PN}-ebluez ${PN}-test-gui"
+FILES_${PN}-enotify = "${libdir}/libenotify.so.* ${bindir}/e-notify-send"
+FILES_${PN}-edbus = "${libdir}/libedbus.so.*"
+FILES_${PN}-enm = "${libdir}/libenm.so.*"
+FILES_${PN}-ehal = "${libdir}/libehal.so.*"
+FILES_${PN}-econnman = "${libdir}/libeconnman.so.*"
+FILES_${PN}-eofono = "${libdir}/libeofono.so.*"
+FILES_${PN}-eukit = "${libdir}/libeukit.so.*"
+FILES_${PN}-ebluez = "${libdir}/libebluez.so.*"
+FILES_${PN}-test-gui = "${bindir}/e_dbus_hal"
+
+RREPLACES_${PN}-enotify = "libenotify1"
+RREPLACES_${PN}-edbus = "edbus"
+RREPLACES_${PN}-enm = "edbus"
+RREPLACES_${PN}-ehal = "edbus"
+RREPLACES_${PN}-econnman = "edbus"
+RREPLACES_${PN}-eofono = "edbus"
+RREPLACES_${PN}-eukit = "edbus"
+RREPLACES_${PN}-ebluez = "edbus"
+
diff --git a/recipes/efl1/edbus_1.0.0.bb b/recipes/efl1/edbus_1.0.0.bb
new file mode 100644
index 0000000000..5487f79269
--- /dev/null
+++ b/recipes/efl1/edbus_1.0.0.bb
@@ -0,0 +1,11 @@
+require edbus.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "\
+ ${E_MIRROR}/${SRCNAME}-${PV}.tar.gz \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "4a3031a41e7e33f843cf104bf84cd4ee"
+SRC_URI[sha256sum] = "701be8c07fd460fc3c0fa37f4753ceb5ef87cd5563f1ce5376fa486cf1a4acb5"
diff --git a/recipes/efl1/edbus_svn.bb b/recipes/efl1/edbus_svn.bb
index 8d10370596..646c379aab 100644
--- a/recipes/efl1/edbus_svn.bb
+++ b/recipes/efl1/edbus_svn.bb
@@ -1,35 +1,11 @@
-DESCRIPTION = "DBus and HAL convenience wrappers for EFL"
-DEPENDS = "dbus ecore"
-LICENSE = "MIT BSD"
-PV = "0.5.0.060+svnr${SRCPV}"
-PR = "r3"
-SRCREV = "${EFL_SRCREV}"
+require edbus.inc
-inherit efl
+SRCREV = "${EFL_SRCREV}"
+PV = "1.0.999+svnr${SRCPV}"
+PR = "${INC_PR}.0"
+DEFAULT_PREFERENCE = "-1"
-SRCNAME = "e_dbus"
-SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+SRC_URI = "\
+ ${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep \
+"
S = "${WORKDIR}/${SRCNAME}"
-
-EXTRA_OECONF = "--enable-build-test-gui"
-
-PACKAGES =+ "${PN}-enotify ${PN}-edbus ${PN}-enm ${PN}-ehal ${PN}-econnman ${PN}-eofono ${PN}-eukit ${PN}-ebluez ${PN}-test-gui"
-FILES_${PN}-enotify = "${libdir}/libenotify.so.* ${bindir}/e-notify-send"
-FILES_${PN}-edbus = "${libdir}/libedbus.so.*"
-FILES_${PN}-enm = "${libdir}/libenm.so.*"
-FILES_${PN}-ehal = "${libdir}/libehal.so.*"
-FILES_${PN}-econnman = "${libdir}/libeconnman.so.*"
-FILES_${PN}-eofono = "${libdir}/libeofono.so.*"
-FILES_${PN}-eukit = "${libdir}/libeukit.so.*"
-FILES_${PN}-ebluez = "${libdir}/libebluez.so.*"
-FILES_${PN}-test-gui = "${bindir}/e_dbus_hal"
-
-RREPLACES_${PN}-enotify = "libenotify1"
-RREPLACES_${PN}-edbus = "edbus"
-RREPLACES_${PN}-enm = "edbus"
-RREPLACES_${PN}-ehal = "edbus"
-RREPLACES_${PN}-econnman = "edbus"
-RREPLACES_${PN}-eofono = "edbus"
-RREPLACES_${PN}-eukit = "edbus"
-RREPLACES_${PN}-ebluez = "edbus"
-