aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cwiid/cwiid_git.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-11-27 13:18:53 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-11-27 13:28:28 +0100
commitf2a9c8045666402811c4e5adeccb62ee2042e0c9 (patch)
tree99f41f4bf0746a1d1d069357acd8ab852eb9b6ad /recipes/cwiid/cwiid_git.bb
parente8115ed383040348050284c6ea02913e35236d26 (diff)
downloadopenembedded-f2a9c8045666402811c4e5adeccb62ee2042e0c9.tar.gz
cwiid: updated & fixed SRC_URI
The svn repo does not exist any more and is replaced by git changed the SRC_URI for this also moved to git head (which is already 10 months old) Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cwiid/cwiid_git.bb')
-rw-r--r--recipes/cwiid/cwiid_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/cwiid/cwiid_git.bb b/recipes/cwiid/cwiid_git.bb
new file mode 100644
index 0000000000..a06039f5fb
--- /dev/null
+++ b/recipes/cwiid/cwiid_git.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "wiimote library + tools"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://abstrakraft.org/cwiid/"
+
+SRCREV = "fadf11e89b579bcc0336a0692ac15c93785f3f82"
+PV = "0.6.00+gitr${SRCREV}"
+
+inherit autotools
+inherit distutils-base
+
+export BUILD_SYS
+export HOST_SYS
+
+PARALLEL_MAKE = ""
+
+SRC_URI = "git://github.com/abstrakraft/cwiid.git;protocol=git"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = "--disable-ldconfig"
+
+FILES_${PN} += "\
+ ${sysconfdir}/cwiid/ \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/cwiid/plugins/.debug \
+"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+