aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2010-09-07 10:07:54 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-07 10:07:54 +0200
commit8d64681eb7e2fa74be5dfd2f5a945f57d61113b9 (patch)
tree8fcba04a1f89f10cd065f2f3b80fc023efaafba5 /recipes/clutter/clutter
parent2eca1eb59ccb0890e4db078a4af456c9f2d194ad (diff)
downloadopenembedded-8d64681eb7e2fa74be5dfd2f5a945f57d61113b9.tar.gz
clutter: clean builds for clutter 1.0
* all 0.9 recipes (are actually 1.0rc) & files referenced were removed * all 0.8 recipes were renamed to clutter*-0.8 to ensure parallel installation with later versions * clutter-common.inc as container for helpers was created (also from clutter-fpu.inc) * clutter-1.0_1.0.10.bb was renamed to clutter_1.0.10.bb * clutter-gst_1.2.0.bb introduced the first ever buildable in GLES environment without further effords * clutter-gtk_0.10.2.bb is the latest version which supports clutter 1.0.x (later ones complain on configure for clutter 1.2.x) * clutter* examples / tests are build properly and packed in extra packages. For clutter-interactive tests menu entries (graphics) are added / test-conformance-run runs all conformance tests (crashing tests do not abort) Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/clutter/clutter')
-rw-r--r--recipes/clutter/clutter/enable-tests-r2990.patch50
-rw-r--r--recipes/clutter/clutter/sample.desktop9
-rw-r--r--recipes/clutter/clutter/test-conformance-run8
3 files changed, 17 insertions, 50 deletions
diff --git a/recipes/clutter/clutter/enable-tests-r2990.patch b/recipes/clutter/clutter/enable-tests-r2990.patch
deleted file mode 100644
index 4f449b1177..0000000000
--- a/recipes/clutter/clutter/enable-tests-r2990.patch
+++ /dev/null
@@ -1,50 +0,0 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-Index: clutter/tests/Makefile.am
-===================================================================
---- clutter.orig/tests/Makefile.am 2008-06-26 16:46:26.000000000 +0100
-+++ clutter/tests/Makefile.am 2008-06-26 16:46:50.000000000 +0100
-@@ -1,4 +1,4 @@
--noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
-+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
- test-actors test-behave test-text test-entry test-project \
- test-perspective test-rotate test-depth \
- test-threads test-timeline test-timeline-dup-frames \
-@@ -17,8 +17,8 @@
- test-invariants
-
- if X11_TESTS
--noinst_PROGRAMS += test-pixmap
--noinst_PROGRAMS += test-devices
-+bin_PROGRAMS += test-pixmap
-+bin_PROGRAMS += test-devices
- endif
-
- INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter
-@@ -73,4 +73,9 @@
- test_invariants_SOURCES = test-invariants.c
- test_devices_SOURCES = test-devices.c
-
-+test_textdir = $(pkgdatadir)
-+test_text_DATA = test-text.c
-+test_actorsdir = $(pkgdatadir)
-+test_actors_DATA = redhand.png
-+
- EXTRA_DIST = redhand.png test-script.json
-Index: clutter/tests/test-actors.c
-===================================================================
---- clutter.orig/tests/test-actors.c 2008-06-26 16:46:26.000000000 +0100
-+++ clutter/tests/test-actors.c 2008-06-26 16:46:31.000000000 +0100
-@@ -195,7 +195,7 @@
- /* Create a texture from file, then clone in to same resources */
- if (i == 0)
- {
-- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
-+ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
- &error)) == NULL)
- {
- g_error ("image load failed: %s", error->message);
diff --git a/recipes/clutter/clutter/sample.desktop b/recipes/clutter/clutter/sample.desktop
new file mode 100644
index 0000000000..34dec2b618
--- /dev/null
+++ b/recipes/clutter/clutter/sample.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=NAME
+Comment=Clutter Test
+Exec=EXEC
+Icon=star
+Type=Application
+Categories=Graphics;
+
diff --git a/recipes/clutter/clutter/test-conformance-run b/recipes/clutter/clutter/test-conformance-run
new file mode 100644
index 0000000000..7efd896050
--- /dev/null
+++ b/recipes/clutter/clutter/test-conformance-run
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+# Simple script to run all conformance tests.
+# Works around abortion on crash
+for i in `test-conformance -l` ; do
+ test-conformance $@ -p $i
+done
+