aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/beagleboard
diff options
context:
space:
mode:
authorJoel A Fernandes <agnel.joel@gmail.com>2011-07-16 09:19:58 +0000
committerKoen Kooi <koen@openembedded.org>2011-07-19 09:48:57 +0200
commit14795a321724fbca4803a4f899b8eac47cb005bd (patch)
tree6990fe4d7650780bada610c5fec8bb785718a286 /recipes/beagleboard
parent82e76a4d64b0bd3328514780c077cdd77108057b (diff)
downloadopenembedded-14795a321724fbca4803a4f899b8eac47cb005bd.tar.gz
beagleboard-test-scripts: BeagleBoard userbutton detection for flashing
* Build and install a userbutton tool to detect state of the user button on a BeagleBoard from /dev/input/event0 * Install a user.txt and uEnv.txt to /boot, Narcissus will copy from here to the FAT partition of an SD Card Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/beagleboard')
-rw-r--r--recipes/beagleboard/beagleboard-test-scripts_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes/beagleboard/beagleboard-test-scripts_git.bb b/recipes/beagleboard/beagleboard-test-scripts_git.bb
index 0ee7954f02..bb0e6e4e5f 100644
--- a/recipes/beagleboard/beagleboard-test-scripts_git.bb
+++ b/recipes/beagleboard/beagleboard-test-scripts_git.bb
@@ -1,18 +1,22 @@
## Reminder: The correct spacing for a variable is FOO = "BAR" in : PR="r1"
DESCRIPTION = "BeagleBoard test scripts"
HOMEPAGE = "http://beagleboad.org/support"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://gitorious.org/~joelf/beagleboard-validation/validation-scripts.git;protocol=git \
"
-SRCREV = "2df76857155fbd462527c2b00ee83214483f0594"
+SRCREV = "f7ba1b49190003af524f1a768ec887955a9994a0"
S = "${WORKDIR}/git"
inherit update-rc.d
INITSCRIPT_NAME = "flash-nand-fs.sh"
INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
+do_compile() {
+ ${CC} -o userbutton-pressed ${CFLAGS} ${LDFLAGS} flashing/userbutton-pressed.c
+}
+
do_install() {
TEST_FILES=" \
testaudio \
@@ -36,4 +40,8 @@ do_install() {
# We also register it as an init script so that the SD Card auto-flashes to NAND during boot.
install -d ${D}/${sysconfdir}/init.d/
install -m 0755 ${S}/flashing/flash-nand-fs.sh ${D}/${sysconfdir}/init.d/flash-nand-fs.sh
+ install -m 0755 userbutton-pressed ${D}/${bindir}/userbutton-pressed
+ install -d ${D}/boot/
+ install -m 0755 ${S}/flashing/user.txt ${D}/boot/user.txt
+ install -m 0755 ${S}/flashing/uEnv.txt ${D}/boot/uEnv.txt
}