aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apr
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2011-03-13 15:32:37 +0100
committerEric Bénard <eric@eukrea.com>2011-03-13 22:09:45 +0100
commit1eeaa5402470b1d4f3d282e79167dc6459f1d208 (patch)
treebfb8298f0cb6d53cb7063a03e428b33983e670e9 /recipes/apr
parent915eafb0b5b1509360f1ea63e54673da7a330c91 (diff)
downloadopenembedded-1eeaa5402470b1d4f3d282e79167dc6459f1d208.tar.gz
apr: add 1.4.2
Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/apr')
-rw-r--r--recipes/apr/apr_1.4.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/apr/apr_1.4.2.bb b/recipes/apr/apr_1.4.2.bb
new file mode 100644
index 0000000000..0595731af7
--- /dev/null
+++ b/recipes/apr/apr_1.4.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Apache Portable Runtime (APR) library"
+SECTION = "libs"
+LICENSE = "Apache License, Version 2.0"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
+ file://configure_fixes.patch \
+ file://configfix.patch"
+
+inherit autotools lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+ echo "top_builddir=@apr_builddir@" >> ${S}/Makefile.in
+}
+
+FILES_${PN}-dev += "${datadir}/build-1/* ${libdir}/apr.exp"
+
+do_install_append() {
+ install -d ${D}${datadir}/apr
+ cp ${S}/build/apr_rules.mk ${D}${datadir}/apr/
+ sed -i s,apr_builddir=.*,apr_builddir=,g ${D}${datadir}/apr/apr_rules.mk
+ sed -i s,apr_builders=.*,apr_builders=,g ${D}${datadir}/apr/apr_rules.mk
+ sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${HOST_SYS}-libtool,g ${D}${datadir}/apr/apr_rules.mk
+ sed -i s,\$\(apr_builders\),${D}${datadir}/apr/,g ${D}${datadir}/apr/apr_rules.mk
+ cp ${S}/build/mkdir.sh ${D}${datadir}/apr/
+ cp ${S}/build/make_exports.awk ${D}${datadir}/apr/
+ cp ${S}/build/make_var_export.awk ${D}${datadir}/apr/
+ cp ${S}/${HOST_SYS}-libtool ${D}${datadir}/build-1/libtool
+}
+
+SRC_URI[md5sum] = "4b00e8f70c067893d075577962656b35"
+SRC_URI[sha256sum] = "2017ca700694d09d2b0b21dd7c4d195e43a48735aac88526160c6195ee8f5391"