aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2008-11-17 15:26:19 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2008-11-17 15:26:19 +0100
commitedccb239325861cc2173373a193e811f51ae3b5a (patch)
tree7b66c222c7e49c677cf604dd95288c1b86fc2f5e /packages
parent703e0ac168d6208ce65947930ab253cf7d9c7789 (diff)
parentfc935de948bc9f9235bea14a525f71cc819cfc17 (diff)
downloadopenembedded-edccb239325861cc2173373a193e811f51ae3b5a.tar.gz
Merge branch 'org.openembedded.dev' of ssh://git@git.openembedded.net/openembedded into org.openembedded.dev
Diffstat (limited to 'packages')
-rw-r--r--packages/angstrom/angstrom-x11vnc-xinit.bb14
-rw-r--r--packages/linux/linux_2.6.24.bb5
-rw-r--r--packages/u-boot/u-boot_1.1.2.bb2
3 files changed, 21 insertions, 0 deletions
diff --git a/packages/angstrom/angstrom-x11vnc-xinit.bb b/packages/angstrom/angstrom-x11vnc-xinit.bb
new file mode 100644
index 0000000000..ee21d81e03
--- /dev/null
+++ b/packages/angstrom/angstrom-x11vnc-xinit.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Script to start a passwordless vnc of the current X session"
+LICENSE = "MIT"
+RDEPENDS = "x11vnc"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/X11/Xinit.d
+ echo "#!/bin/sh" > ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+ echo "x11vnc -q -bg -display :0 -forever -avahi" >> ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+ chmod 0755 ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+}
+
+CONFFILES_${PN} += "${sysconfdir}/X11/Xinit.d/02vnc"
+PACKAGE_ARCH = "all"
+
diff --git a/packages/linux/linux_2.6.24.bb b/packages/linux/linux_2.6.24.bb
index e787663bc7..40c23237fb 100644
--- a/packages/linux/linux_2.6.24.bb
+++ b/packages/linux/linux_2.6.24.bb
@@ -8,6 +8,7 @@ DEFAULT_PREFERENCE_simpad = "1"
DEFAULT_PREFERENCE_atngw100 = "1"
DEFAULT_PREFERENCE_at32stk1000 = "1"
DEFAULT_PREFERENCE_ts72xx = "1"
+DEFAULT_PREFERENCE_oxe810 = "1"
DEFAULT_PREFERENCE_cs-e9302 = "1"
PR = "r17"
@@ -82,6 +83,10 @@ SRC_URI_append_ts72xx = "\
file://ts72xx-use-cpld-reset.patch;patch=1 \
file://ts72xx-rs485.patch;patch=1"
+SRC_URI_append_oxe810 = " \
+ file://oxe810.diff;patch=1 \
+ "
+
CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
FILES_kernel-image_gesbc-9302 = ""
diff --git a/packages/u-boot/u-boot_1.1.2.bb b/packages/u-boot/u-boot_1.1.2.bb
index 8287d35a1d..1afb3eec5a 100644
--- a/packages/u-boot/u-boot_1.1.2.bb
+++ b/packages/u-boot/u-boot_1.1.2.bb
@@ -13,6 +13,7 @@ SRC_URI_append_mnci = "file://mnci.patch;patch=1 \
file://command-names.patch;patch=1"
SRC_URI_append_magicbox = "file://u-boot-emetec.patch;patch=1 "
+SRC_URI_append_oxe810 = "file://oxe810.patch;patch=1 "
# TODO: SRC_URI_append_rt3000
@@ -22,6 +23,7 @@ TARGET_LDFLAGS = ""
UBOOT_MACHINE_mnci = "mnci_config"
UBOOT_MACHINE_vibren = "pxa255_idp_config"
UBOOT_MACHINE_magicbox = "EMETEC405_config"
+UBOOT_MACHINE_oxe810 = "oxnas_config"
inherit base