aboutsummaryrefslogtreecommitdiffstats
path: root/packages/vsftpd
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-23 14:10:29 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-23 14:10:29 +0000
commit44e10367f2ef64428e1ce6e4534814d91f531eb1 (patch)
treebde2afc7ba09390ca9f24f35c5a880fd4b1485bc /packages/vsftpd
parent3c5f9f0a3ec98f4dddd1130a7e553e2f5550ae1c (diff)
downloadopenembedded-44e10367f2ef64428e1ce6e4534814d91f531eb1.tar.gz
vsftpd: Fix dependencies. Fix uclibc support.
Diffstat (limited to 'packages/vsftpd')
-rw-r--r--packages/vsftpd/vsftpd-2.0.5/syscall.patch12
-rw-r--r--packages/vsftpd/vsftpd_2.0.5.bb6
2 files changed, 15 insertions, 3 deletions
diff --git a/packages/vsftpd/vsftpd-2.0.5/syscall.patch b/packages/vsftpd/vsftpd-2.0.5/syscall.patch
new file mode 100644
index 0000000000..b91cd5392b
--- /dev/null
+++ b/packages/vsftpd/vsftpd-2.0.5/syscall.patch
@@ -0,0 +1,12 @@
+Index: vsftpd-2.0.5/sysdeputil.c
+===================================================================
+--- vsftpd-2.0.5.orig/sysdeputil.c 2007-05-20 21:20:01.000000000 +0200
++++ vsftpd-2.0.5/sysdeputil.c 2007-05-20 21:20:28.000000000 +0200
+@@ -159,7 +159,6 @@
+ #include <linux/capability.h>
+ #include <errno.h>
+ #include <syscall.h>
+-_syscall2(int, capset, cap_user_header_t, header, const cap_user_data_t, data)
+ /* Gross HACK to avoid warnings - linux headers overlap glibc headers */
+ #undef __NFDBITS
+ #undef __FDMASK
diff --git a/packages/vsftpd/vsftpd_2.0.5.bb b/packages/vsftpd/vsftpd_2.0.5.bb
index 81aec46845..fc10d27f08 100644
--- a/packages/vsftpd/vsftpd_2.0.5.bb
+++ b/packages/vsftpd/vsftpd_2.0.5.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "Secure ftp daemon"
SECTION = "console/network"
LICENSE = "GPL"
-DEPENDS = "openssl"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://vsftpd.beasts.org/users/cevans/vsftpd-${PV}.tar.gz \
file://makefile.patch;patch=1 \
file://nopam.patch;patch=1 \
+ file://syscall.patch;patch=1 \
file://init \
file://vsftpd.conf"
@@ -20,7 +20,7 @@ do_configure() {
}
do_compile() {
- oe_runmake "LIBS=-lssl -lcrypto -lcrypt -L${STAGING_LIBDIR}"
+ oe_runmake "LIBS=-lcrypt -L${STAGING_LIBDIR}"
}
do_install() {