aboutsummaryrefslogtreecommitdiffstats
path: root/packages/update-modules/update-modules_1.0.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-08-29 13:06:20 +0000
committerRod Whitby <rod@whitby.id.au>2007-08-29 13:06:20 +0000
commite842d3ccb51cc5a7feb0f2d573ce6f22330b4f46 (patch)
treef9e341a23608fcc1f846021ae0079ed52fb206d4 /packages/update-modules/update-modules_1.0.bb
parent6cd817942e46d2b17174893ed7f519976162a82e (diff)
downloadopenembedded-e842d3ccb51cc5a7feb0f2d573ce6f22330b4f46.tar.gz
update-modules: Insert special case work-around for a legacy corner case of a machine which supports a 2.6 kernel but is used in a distro which must use a 2.4 kernel. It's ugly, just look away now. It has the blessing of RP and hrw, however.
Diffstat (limited to 'packages/update-modules/update-modules_1.0.bb')
-rw-r--r--packages/update-modules/update-modules_1.0.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/packages/update-modules/update-modules_1.0.bb b/packages/update-modules/update-modules_1.0.bb
index dadcddb8c3..cc7a585207 100644
--- a/packages/update-modules/update-modules_1.0.bb
+++ b/packages/update-modules/update-modules_1.0.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Script to manage module configuration files"
LICENSE = "GPLv2"
PACKAGE_ARCH = "all"
RDEPENDS = "${@base_contains("MACHINE_FEATURES", "kernel26", "module-init-tools-depmod","modutils-depmod",d)} "
-PR = "r5"
+PR = "r6"
SRC_URI = "file://update-modules"
@@ -18,3 +18,13 @@ do_install() {
install -d ${D}${sbindir}
install ${WORKDIR}/update-modules ${D}${sbindir}
}
+
+# The Unslung distro uses a 2.4 kernel for a machine (the NSLU2) which
+# supports both 2.4 and 2.6 kernels. Rather than forcing OE to have
+# to deal with that unique legacy corner case, we just nullify the
+# RDEPENDS here and handle it in the Unslung image recipe. I know this
+# is ugly. Please don't remove it unless you first make the RDEPENDS
+# line at the top of this file understand that a machine can be used
+# in both a 2.4 kernel distro and a 2.6 kernel distro. Really, it's
+# not worth the effort to do that, so just overlook the next line.
+RDEPENDS_unslung = ""