aboutsummaryrefslogtreecommitdiffstats
path: root/packages/samba
diff options
context:
space:
mode:
authorØyvind Repvik <repvik@foonas.org>2008-12-07 20:59:56 +0100
committerØyvind Repvik <repvik@foonas.org>2008-12-07 21:05:17 +0100
commit52379ecee3d7c3a2a9b0ecd49c5ca164d182c345 (patch)
tree268f05cbdb6c659fc77468589c262f0ffd14d4f0 /packages/samba
parent9e89e6633626ebb9f1af0694bc06f0a101e55d03 (diff)
downloadopenembedded-52379ecee3d7c3a2a9b0ecd49c5ca164d182c345.tar.gz
samba:
Add samba 3.0.33, thanks to timtimred.
Diffstat (limited to 'packages/samba')
-rw-r--r--packages/samba/samba-3.0.33/configure.patch213
-rw-r--r--packages/samba/samba-3.0.33/smb.conf266
-rw-r--r--packages/samba/samba_3.0.33.bb56
3 files changed, 535 insertions, 0 deletions
diff --git a/packages/samba/samba-3.0.33/configure.patch b/packages/samba/samba-3.0.33/configure.patch
new file mode 100644
index 0000000000..ddcb9e9a15
--- /dev/null
+++ b/packages/samba/samba-3.0.33/configure.patch
@@ -0,0 +1,213 @@
+diff -urN source.old//aclocal.m4 source//aclocal.m4
+--- source.old//aclocal.m4 2008-08-25 22:09:21.000000000 +0100
++++ source//aclocal.m4 2008-11-23 17:44:58.050646210 +0000
+@@ -1,5 +1,5 @@
+ dnl test whether dirent has a d_off member
+-AC_DEFUN(AC_DIRENT_D_OFF,
++AC_DEFUN([AC_DIRENT_D_OFF],
+ [AC_CACHE_CHECK([for d_off in dirent], ac_cv_dirent_d_off,
+ [AC_TRY_COMPILE([
+ #include <unistd.h>
+@@ -13,7 +13,7 @@
+
+ dnl Mark specified module as shared
+ dnl SMB_MODULE(name,static_files,shared_files,subsystem,whatif-static,whatif-shared)
+-AC_DEFUN(SMB_MODULE,
++AC_DEFUN([SMB_MODULE],
+ [
+ AC_MSG_CHECKING([how to build $1])
+ if test "$[MODULE_][$1]"; then
+@@ -44,7 +44,7 @@
+ fi
+ ])
+
+-AC_DEFUN(SMB_SUBSYSTEM,
++AC_DEFUN([SMB_SUBSYSTEM],
+ [
+ AC_SUBST($1_STATIC)
+ AC_SUBST($1_MODULES)
+@@ -229,7 +229,7 @@
+
+ dnl Define an AC_DEFINE with ifndef guard.
+ dnl AC_N_DEFINE(VARIABLE [, VALUE])
+-define(AC_N_DEFINE,
++define([AC_N_DEFINE],
+ [cat >> confdefs.h <<\EOF
+ [#ifndef] $1
+ [#define] $1 ifelse($#, 2, [$2], $#, 3, [$2], 1)
+@@ -239,14 +239,14 @@
+
+ dnl Add an #include
+ dnl AC_ADD_INCLUDE(VARIABLE)
+-define(AC_ADD_INCLUDE,
++define([AC_ADD_INCLUDE],
+ [cat >> confdefs.h <<\EOF
+ [#include] $1
+ EOF
+ ])
+
+ dnl Copied from libtool.m4
+-AC_DEFUN(AC_PROG_LD_GNU,
++AC_DEFUN([AC_PROG_LD_GNU],
+ [AC_CACHE_CHECK([if the linker ($LD) is GNU ld], ac_cv_prog_gnu_ld,
+ [# I'd rather use --version here, but apparently some GNU ld's only accept -v.
+ if $LD -v 2>&1 </dev/null | egrep '(GNU|with BFD)' 1>&5; then
+@@ -257,7 +257,7 @@
+ ])
+
+ dnl Removes -I/usr/include/? from given variable
+-AC_DEFUN(CFLAGS_REMOVE_USR_INCLUDE,[
++AC_DEFUN([CFLAGS_REMOVE_USR_INCLUDE],[
+ ac_new_flags=""
+ for i in [$]$1; do
+ case [$]i in
+@@ -270,7 +270,7 @@
+
+ dnl Removes '-L/usr/lib[/]', '-Wl,-rpath,/usr/lib[/]'
+ dnl and '-Wl,-rpath -Wl,/usr/lib[/]' from given variable
+-AC_DEFUN(LIB_REMOVE_USR_LIB,[
++AC_DEFUN([LIB_REMOVE_USR_LIB],[
+ ac_new_flags=""
+ l=""
+ for i in [$]$1; do
+@@ -301,7 +301,7 @@
+
+ dnl From Bruno Haible.
+
+-AC_DEFUN(jm_ICONV,
++AC_DEFUN([jm_ICONV],
+ [
+ dnl Some systems have iconv in libc, some have it in libiconv (OSF/1 and
+ dnl those with the standalone portable libiconv installed).
+@@ -387,7 +387,7 @@
+ fi
+ ])
+
+-AC_DEFUN(rjs_CHARSET,[
++AC_DEFUN([rjs_CHARSET],[
+ dnl Find out if we can convert from $1 to UCS2-LE
+ AC_MSG_CHECKING([can we convert from $1 to UCS2-LE?])
+ AC_TRY_RUN([
+@@ -405,7 +405,7 @@
+
+ dnl CFLAGS_ADD_DIR(CFLAGS, $INCDIR)
+ dnl This function doesn't add -I/usr/include into CFLAGS
+-AC_DEFUN(CFLAGS_ADD_DIR,[
++AC_DEFUN([CFLAGS_ADD_DIR],[
+ if test "$2" != "/usr/include" ; then
+ $1="$$1 -I$2"
+ fi
+@@ -413,7 +413,7 @@
+
+ dnl LIB_ADD_DIR(LDFLAGS, $LIBDIR)
+ dnl This function doesn't add -L/usr/lib into LDFLAGS
+-AC_DEFUN(LIB_ADD_DIR,[
++AC_DEFUN([LIB_ADD_DIR],[
+ if test "$2" != "/usr/lib" ; then
+ $1="$$1 -L$2"
+ fi
+@@ -486,7 +486,7 @@
+ dnl AC_TRY_RUN_STRICT(PROGRAM,CFLAGS,CPPFLAGS,LDFLAGS,
+ dnl [ACTION-IF-TRUE],[ACTION-IF-FALSE],
+ dnl [ACTION-IF-CROSS-COMPILING = RUNTIME-ERROR])
+-AC_DEFUN( [AC_TRY_RUN_STRICT],
++AC_DEFUN([AC_TRY_RUN_STRICT],
+ [
+ old_CFLAGS="$CFLAGS";
+ CFLAGS="$2";
+diff -urN source.old//configure.in source//configure.in
+--- source.old//configure.in 2008-08-25 22:09:21.000000000 +0100
++++ source//configure.in 2008-11-23 17:22:17.108791515 +0000
+@@ -1402,7 +1402,7 @@
+ #endif
+ exit(0);
+ }
+-], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
++], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no], [linux_getgrouplist_ok=cross])
+ if test x"$linux_getgrouplist_ok" = x"yes"; then
+ AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
+ fi
+diff -urN source.old//lib/replace/libreplace.m4 source//lib/replace/libreplace.m4
+--- source.old//lib/replace/libreplace.m4 2008-08-25 22:09:21.000000000 +0100
++++ source//lib/replace/libreplace.m4 2008-11-23 17:54:27.942153096 +0000
+@@ -1,4 +1,4 @@
+-AC_DEFUN_ONCE(AC_LIBREPLACE_LOCATION_CHECKS,
++AC_DEFUN_ONCE([AC_LIBREPLACE_LOCATION_CHECKS],
+ [
+ echo "LIBREPLACE_LOCATION_CHECKS: START"
+
+@@ -27,7 +27,7 @@
+ ]) dnl end AC_LIBREPLACE_LOCATION_CHECKS
+
+
+-AC_DEFUN_ONCE(AC_LIBREPLACE_BROKEN_CHECKS,
++AC_DEFUN_ONCE([AC_LIBREPLACE_BROKEN_CHECKS],
+ [
+ echo "LIBREPLACE_BROKEN_CHECKS: START"
+
+@@ -325,25 +325,25 @@
+ AC_DEFINE(HAVE_VOLATILE, 1, [Whether the C compiler understands volatile])
+ fi
+
+-m4_include(system/config.m4)
++m4_include(lib/replace/system/config.m4)
+
+-m4_include(dlfcn.m4)
+-m4_include(getpass.m4)
+-m4_include(strptime.m4)
+-m4_include(win32.m4)
+-m4_include(timegm.m4)
+-m4_include(repdir.m4)
++m4_include(lib/replace/dlfcn.m4)
++m4_include(lib/replace/getpass.m4)
++m4_include(lib/replace/strptime.m4)
++m4_include(lib/replace/win32.m4)
++m4_include(lib/replace/timegm.m4)
++m4_include(lib/replace/repdir.m4)
+
+ AC_CHECK_FUNCS([syslog memset memcpy],,[AC_MSG_ERROR([Required function not found])])
+
+ echo "LIBREPLACE_BROKEN_CHECKS: END"
+ ]) dnl end AC_LIBREPLACE_BROKEN_CHECKS
+
+-AC_DEFUN_ONCE(AC__LIBREPLACE_ALL_CHECKS_START,
++AC_DEFUN_ONCE([AC__LIBREPLACE_ALL_CHECKS_START],
+ [
+ #LIBREPLACE_ALL_CHECKS: START"
+ ])
+-AC_DEFUN_ONCE(AC__LIBREPLACE_ALL_CHECKS_END,
++AC_DEFUN_ONCE([AC__LIBREPLACE_ALL_CHECKS_END],
+ [
+ #LIBREPLACE_ALL_CHECKS: END"
+ ])
+@@ -356,6 +356,6 @@
+ AC__LIBREPLACE_ALL_CHECKS_END
+ ])
+
+-m4_include(libreplace_cc.m4)
+-m4_include(libreplace_macros.m4)
+-m4_include(autoconf-2.60.m4)
++m4_include(lib/replace/libreplace_cc.m4)
++m4_include(lib/replace/libreplace_macros.m4)
++m4_include(lib/replace/autoconf-2.60.m4)
+diff -urN source.old//lib/replace/libreplace_macros.m4 source//lib/replace/libreplace_macros.m4
+--- source.old//lib/replace/libreplace_macros.m4 2008-08-25 22:09:21.000000000 +0100
++++ source//lib/replace/libreplace_macros.m4 2008-11-23 17:31:08.269791372 +0000
+@@ -76,7 +76,7 @@
+ ])
+
+ dnl AC_PROG_CC_FLAG(flag)
+-AC_DEFUN(AC_PROG_CC_FLAG,
++AC_DEFUN([AC_PROG_CC_FLAG],
+ [AC_CACHE_CHECK(whether ${CC-cc} accepts -$1, ac_cv_prog_cc_$1,
+ [echo 'void f(){}' > conftest.c
+ if test -z "`${CC-cc} -$1 -c conftest.c 2>&1`"; then
+@@ -103,7 +103,7 @@
+ dnl see if a declaration exists for a function or variable
+ dnl defines HAVE_function_DECL if it exists
+ dnl AC_HAVE_DECL(var, includes)
+-AC_DEFUN(AC_HAVE_DECL,
++AC_DEFUN([AC_HAVE_DECL],
+ [
+ AC_CACHE_CHECK([for $1 declaration],ac_cv_have_$1_decl,[
+ AC_TRY_COMPILE([$2],[int i = (int)$1],
diff --git a/packages/samba/samba-3.0.33/smb.conf b/packages/samba/samba-3.0.33/smb.conf
new file mode 100644
index 0000000000..3854621c3e
--- /dev/null
+++ b/packages/samba/samba-3.0.33/smb.conf
@@ -0,0 +1,266 @@
+# This is the main Samba configuration file. You should read the
+# smb.conf(5) manual page in order to understand the options listed
+# here. Samba has a huge number of configurable options (perhaps too
+# many!) most of which are not shown in this example
+#
+# For a step to step guide on installing, configuring and using samba,
+# read the Samba-HOWTO-Collection. This may be obtained from:
+# http://www.samba.org/samba/docs/Samba-HOWTO-Collection.pdf
+#
+# Many working examples of smb.conf files can be found in the
+# Samba-Guide which is generated daily and can be downloaded from:
+# http://www.samba.org/samba/docs/Samba-Guide.pdf
+#
+# Any line which starts with a ; (semi-colon) or a # (hash)
+# is a comment and is ignored. In this example we will use a #
+# for commentry and a ; for parts of the config file that you
+# may wish to enable
+#
+# NOTE: Whenever you modify this file you should run the command "testparm"
+# to check that you have not made any basic syntactic errors.
+#
+#======================= Global Settings =====================================
+[global]
+
+# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
+ workgroup = MYGROUP
+
+# server string is the equivalent of the NT Description field
+ server string = Samba Server
+
+# Security mode. Defines in which mode Samba will operate. Possible
+# values are share, user, server, domain and ads. Most people will want
+# user level security. See the Samba-HOWTO-Collection for details.
+ security = user
+
+# This option is important for security. It allows you to restrict
+# connections to machines which are on your local network. The
+# following example restricts access to two C class networks and
+# the "loopback" interface. For more examples of the syntax see
+# the smb.conf man page
+; hosts allow = 192.168.1. 192.168.2. 127.
+
+# If you want to automatically load your printer list rather
+# than setting them up individually then you'll need this
+ load printers = yes
+
+# you may wish to override the location of the printcap file
+; printcap name = /etc/printcap
+
+# on SystemV system setting printcap name to lpstat should allow
+# you to automatically obtain a printer list from the SystemV spool
+# system
+; printcap name = lpstat
+
+# It should not be necessary to specify the print system type unless
+# it is non-standard. Currently supported print systems include:
+# bsd, cups, sysv, plp, lprng, aix, hpux, qnx
+; printing = cups
+
+# Uncomment this if you want a guest account, you must add this to /etc/passwd
+# otherwise the user "nobody" is used
+; guest account = pcguest
+
+# this tells Samba to use a separate log file for each machine
+# that connects
+ log file = /var/log/samba/log.%m
+
+# Put a capping on the size of the log files (in Kb).
+ max log size = 50
+
+# Use password server option only with security = server
+# The argument list may include:
+# password server = My_PDC_Name [My_BDC_Name] [My_Next_BDC_Name]
+# or to auto-locate the domain controller/s
+# password server = *
+; password server = <NT-Server-Name>
+
+# Use the realm option only with security = ads
+# Specifies the Active Directory realm the host is part of
+; realm = MY_REALM
+
+# Backend to store user information in. New installations should
+# use either tdbsam or ldapsam. smbpasswd is available for backwards
+# compatibility. tdbsam requires no further configuration.
+; passdb backend = tdbsam
+
+# Using the following line enables you to customise your configuration
+# on a per machine basis. The %m gets replaced with the netbios name
+# of the machine that is connecting.
+# Note: Consider carefully the location in the configuration file of
+# this line. The included file is read at that point.
+; include = /usr/local/samba/lib/smb.conf.%m
+
+# Configure Samba to use multiple interfaces
+# If you have multiple network interfaces then you must list them
+# here. See the man page for details.
+; interfaces = 192.168.12.2/24 192.168.13.2/24
+
+# Browser Control Options:
+# set local master to no if you don't want Samba to become a master
+# browser on your network. Otherwise the normal election rules apply
+; local master = no
+
+# OS Level determines the precedence of this server in master browser
+# elections. The default value should be reasonable
+; os level = 33
+
+# Domain Master specifies Samba to be the Domain Master Browser. This
+# allows Samba to collate browse lists between subnets. Don't use this
+# if you already have a Windows NT domain controller doing this job
+; domain master = yes
+
+# Preferred Master causes Samba to force a local browser election on startup
+# and gives it a slightly higher chance of winning the election
+; preferred master = yes
+
+# Enable this if you want Samba to be a domain logon server for
+# Windows95 workstations.
+; domain logons = yes
+
+# if you enable domain logons then you may want a per-machine or
+# per user logon script
+# run a specific logon batch file per workstation (machine)
+; logon script = %m.bat
+# run a specific logon batch file per username
+; logon script = %U.bat
+
+# Where to store roving profiles (only for Win95 and WinNT)
+# %L substitutes for this servers netbios name, %U is username
+# You must uncomment the [Profiles] share below
+; logon path = \\%L\Profiles\%U
+
+# Windows Internet Name Serving Support Section:
+# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
+; wins support = yes
+
+# WINS Server - Tells the NMBD components of Samba to be a WINS Client
+# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
+; wins server = w.x.y.z
+
+# WINS Proxy - Tells Samba to answer name resolution queries on
+# behalf of a non WINS capable client, for this to work there must be
+# at least one WINS Server on the network. The default is NO.
+; wins proxy = yes
+
+# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
+# via DNS nslookups. The default is NO.
+ dns proxy = no
+
+# These scripts are used on a domain controller or stand-alone
+# machine to add or delete corresponding unix accounts
+; add user script = /usr/sbin/useradd %u
+; add group script = /usr/sbin/groupadd %g
+; add machine script = /usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false %u
+; delete user script = /usr/sbin/userdel %u
+; delete user from group script = /usr/sbin/deluser %u %g
+; delete group script = /usr/sbin/groupdel %g
+
+
+#============================ Share Definitions ==============================
+[homes]
+ comment = Home Directories
+ browseable = no
+ writable = yes
+
+# Un-comment the following and create the netlogon directory for Domain Logons
+; [netlogon]
+; comment = Network Logon Service
+; path = /usr/local/samba/lib/netlogon
+; guest ok = yes
+; writable = no
+; share modes = no
+
+
+# Un-comment the following to provide a specific roving profile share
+# the default is to use the user's home directory
+;[Profiles]
+; path = /usr/local/samba/profiles
+; browseable = no
+; guest ok = yes
+
+
+# NOTE: If you have a BSD-style print system there is no need to
+# specifically define each individual printer
+[printers]
+ comment = All Printers
+ path = /var/spool/samba
+ browseable = no
+# Set public = yes to allow user 'guest account' to print
+ guest ok = no
+ writable = no
+ printable = yes
+
+# This one is useful for people to share files
+;[tmp]
+; comment = Temporary file space
+; path = /tmp
+; read only = no
+; public = yes
+
+# A publicly accessible directory, but read only, except for people in
+# the "staff" group
+;[public]
+; comment = Public Stuff
+; path = /home/samba
+; public = yes
+; writable = yes
+; printable = no
+; write list = @staff
+
+# Other examples.
+#
+# A private printer, usable only by fred. Spool data will be placed in fred's
+# home directory. Note that fred must have write access to the spool directory,
+# wherever it is.
+;[fredsprn]
+; comment = Fred's Printer
+; valid users = fred
+; path = /homes/fred
+; printer = freds_printer
+; public = no
+# A private directory, usable only by fred. Note that fred requires write
+# access to the directory.
+;[fredsdir]
+; comment = Fred's Service
+; path = /usr/somewhere/private
+; valid users = fred
+; public = no
+; writable = yes
+; printable = no
+
+# a service which has a different directory for each machine that connects
+# this allows you to tailor configurations to incoming machines. You could
+# also use the %U option to tailor it by user name.
+# The %m gets replaced with the machine name that is connecting.
+;[pchome]
+; comment = PC Directories
+; path = /usr/pc/%m
+; public = no
+; writable = yes
+
+# A publicly accessible directory, read/write to all users. Note that all files
+# created in the directory by users will be owned by the default user, so
+# any user with access can delete any other user's files. Obviously this
+# directory must be writable by the default user. Another user could of course
+# be specified, in which case all files would be owned by that user instead.
+;[public]
+; path = /usr/somewhere/else/public
+; public = yes
+; only guest = yes
+; writable = yes
+; printable = no
+
+# The following two entries demonstrate how to share a directory so that two
+# users can place files there that will be owned by the specific users. In this
+# setup, the directory should be writable by both users and should have the
+# sticky bit set on it to prevent abuse. Obviously this could be extended to
+# as many users as required.
+;[myshare]
+; comment = Mary's and Fred's stuff
+; path = /usr/somewhere/shared
+; valid users = mary fred
+; public = no
+; writable = yes
+; printable = no
+; create mask = 0765
diff --git a/packages/samba/samba_3.0.33.bb b/packages/samba/samba_3.0.33.bb
new file mode 100644
index 0000000000..a1aeccf59f
--- /dev/null
+++ b/packages/samba/samba_3.0.33.bb
@@ -0,0 +1,56 @@
+require samba.inc
+inherit update-rc.d
+
+PR = "r8"
+
+SRC_URI += "file://config-lfs.patch;patch=1 \
+ file://quota.patch;patch=1;pnum=0 \
+ file://init \
+ file://smb.conf \
+ "
+
+# file://cifs.patch;patch=1 \
+
+INITSCRIPT_NAME = "samba"
+# No dependencies, goes in at level 20 (NOTE: take care with the
+# level, later levels put the shutdown later too - see the links
+# in rc6.d, the shutdown must precede network shutdown).
+INITSCRIPT_PARAMS = "defaults"
+CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
+
+# The file system settings --foodir=dirfoo and overridden unconditionally
+# in the samba config by --with-foodir=dirfoo - even if the --with is not
+# specified! Fix that here. Set the privatedir to /etc/samba/private.
+EXTRA_OECONF += "\
+ SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+ samba_cv_struct_timespec=yes \
+ --with-configdir=${sysconfdir}/samba \
+ --with-privatedir=${sysconfdir}/samba/private \
+ --with-lockdir=${localstatedir}/lock \
+ --with-piddir=${localstatedir}/run \
+ --with-logfilebase=${localstatedir}/log \
+ --with-libdir=${libdir} \
+ --with-mandir=${mandir} \
+ --with-swatdir=${datadir}/swat \
+ "
+
+do_install_append() {
+ install -d "${D}/var/log/samba"
+ install -d "${D}${sysconfdir}/init.d"
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
+ install -d "${D}${sysconfdir}/samba"
+ install -c -m 644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf
+ install -d ${D}/var/spool/samba
+}
+
+PACKAGES =+ "swat"
+
+FILES_swat = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
+FILES_${PN} += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat \
+ ${libdir}/auth/*.so ${libdir}/security/*.so"
+FILES_${PN}-dbg += "${libdir}/vfs/.debug/*.so ${libdir}/charset/.debug/*.so \
+ ${libdir}/auth/.debug/*.so ${libdir}/security/.debug/*.so"
+
+#
+# bug fix for samba.inc:
+FILES_cifs-doc += "${mandir}/man8/mount.cifs.8"